Excel JOS kaavoja

Hei!

Minun pitäisi saada luotua sellainen excel kaava, jossa olisi JOS ehtoja aika monta kappeletta.

Tämän verran olen kaavaa saanut aikaan, mutta se kusee jo tuossa vaiheessa. Yhdellä lausekkeella se vielä toimii, mutta heti kun laittaa toisen JOS lauseen se menee sekaisin...:/

=B3*((JOS(A3>=5;0.02;Epätosi)JOS(A3>=10;0.03;EPÄTOSI)*(0.25*A5)*G13)))

Ideana on, että kun saraketta A3 muutetaan niin ehto luetaan sen perusteella.Eli jos A3 on suurempi tai yhtäsuuri kuin 5 niin sitten se kerrotaan 0.02 ja seuraava olisi 10 ja kerrotaan 0.03 ja jne... jotenkin tässä tapauksessa vaan se laskee nuo molemmat kaavat nyt :S tai ainakin luulen niin...
Ilmianna
Jaa

4 Vastausta


Tee kaava näin
=B3*JOS(A3>=20;0,05;JOS(A3>=15;0,04;JOS(A3>=10;0,03;JOS(A3>=5;0,02))))
Ilmianna
Jaa
http://img503.imageshack.us/img503/5338/joslauseio1.png

Tuollein ne menee oikein sisäkkäin.
Ilmianna
Jaa
Tuossa on käsittääkseni se ongelma, että kun A3 on 10 tai suurempi, se on myös suurempi kuin 5 eli molemmat ehdot täyttyvät. On ilmeisesti niin, että jos A3>=5 ja A3=10, niin kerroin on 0,03. Tuollaisissa tapauksissa voi käyttää JOS-funktion argumentiksi upotettua JA-funktiota:

=JOS(JA(A3>=5;A3=10;0,03*B3*0,25*A5*G13;EPÄTOSI))
Ilmianna
Jaa
pelkillä boolean operaattoreilla ja on helppolukuisempi ja ei ole sitä jossien 7 sisäkkäissääntoä (ennen versiota 2007)

=(B3*0,25*A5*G13)*((A3>=5)*0,2 (A3>=10)*0,1 (A3>=15)*0,1 (A3>=20)*0,1 (A3>=25)*0,1)
Ilmianna
Jaa

Vastaa alkuperäiseen viestiin

Excel JOS kaavoja

Hei!

Minun pitäisi saada luotua sellainen excel kaava, jossa olisi JOS ehtoja aika monta kappeletta.

Tämän verran olen kaavaa saanut aikaan, mutta se kusee jo tuossa vaiheessa. Yhdellä lausekkeella se vielä toimii, mutta heti kun laittaa toisen JOS lauseen se menee sekaisin...:/

=B3*((JOS(A3>=5;0.02;Epätosi)JOS(A3>=10;0.03;EPÄTOSI)*(0.25*A5)*G13)))

Ideana on, että kun saraketta A3 muutetaan niin ehto luetaan sen perusteella.Eli jos A3 on suurempi tai yhtäsuuri kuin 5 niin sitten se kerrotaan 0.02 ja seuraava olisi 10 ja kerrotaan 0.03 ja jne... jotenkin tässä tapauksessa vaan se laskee nuo molemmat kaavat nyt :S tai ainakin luulen niin...

5000 merkkiä jäljellä

Peruuta