Työajan laskenta + ylityöt

raipen kädet

Ideana olisi sellainen taulukko johon täytetään töihin tulo- ja lähtöaika. Exceli laskisi tästä ajasta töissä oloajan ja erittelisi sitten 50% ja 100% tehdyt tunnit. Eli esim. työaika 7:00-17:30, jolloi excel laskisi työajaksi 8h, 50% tunneiksi 2h ja 100% 0,5h

Ymmärsihän joku?? kolmea kaavaa siis kaivataan!

69

21076

Vastaukset

  • JOSsilla vaan..........

    • sitä onkin oikein paljon apua...


    • neuvoista kirjoitti:

      sitä onkin oikein paljon apua...

      Hei!

      Netistä löytyy Tuntinetti -niminen internet-palvelu, joka osaa eritellä työajan automaattisesti halutun työehtosopimuksen mukaan. Sovellusta voi kokeilla ilmaiseksi: http://www.tuntinetti.fi/index.html

      t. Martin


    • Martin kirjoitti:

      Hei!

      Netistä löytyy Tuntinetti -niminen internet-palvelu, joka osaa eritellä työajan automaattisesti halutun työehtosopimuksen mukaan. Sovellusta voi kokeilla ilmaiseksi: http://www.tuntinetti.fi/index.html

      t. Martin

      martin linkkisi ei toimi


    • ghghghgh kirjoitti:

      martin linkkisi ei toimi

      no eivarmaan kun martin heitti vitoset ja firma meni nurin


  • Solussa C4 töihin tuloaika
    Solussa D4 töistä lähtöaika
    Soluun E4 lasketaan tunnit kaavalla:
    =JOS(D4="";"";JOS(D410/24;1/12;JOS(E4>1/3;E4-1/3;"")))

    Soluun H4 100% tunnit: =JOS
    (E4="";"";JOS(E4 >10/24;E4-10/24;""))

    Kaikissa näissä soluissa muotoiluna Oma [t]mm

    • Kerrassaan mahtavaa! tämä toimi just eikä melkein. Itsellä alkoi olemaan jo niin pitkää IF-lausetta ettei siitä enää selvää saanut. Onneksi on olemassa näitä tyyppejä jotka OSAAVAT auttaa! tänks!


    • Nuohan toimii vaikka vuorokausi vaihtuu työvuoron aikana , mutta miten sais laskettua iltavuoro- ja yövuorotunnit jos iltatunnit 14:00-22:00 ja yötunnit 22:00- 06:00.


    • Prosessimies kirjoitti:

      Nuohan toimii vaikka vuorokausi vaihtuu työvuoron aikana , mutta miten sais laskettua iltavuoro- ja yövuorotunnit jos iltatunnit 14:00-22:00 ja yötunnit 22:00- 06:00.

      Itse tein vastaavan niin että päivä piti katkaista keskiyöllä, eli alkuvuoro erikseen ja loppuvuoro erikseen. Oma järki ei riittänyt yhteen lausekkeeseen. Tuo ensimmäinen ongelmahan olisi ihan - laskua:
      loppuaika-alkuaika= B1-A1 (ruudussa C1)
      C1-10 (ruudussa D1)ja saat vastaukseksi 100%tunnit
      D1-C1 (ruudussa F1) ja saat vastaukseksi 50% tunnit
      C1-D1-F1 ja tulee se 0% tunnit.
      Tämä nyt vain ihan selvyyden vuoksi ettei aina tarvi kauheita kaavoja.

      Omassa tunti-ilmoituspohjassa yölisät erotellaan aktiiveista näin (yötä aamulla ja illalla, 24h vuorot); =JOS(JA(E2>=O59;E2P59;M2>=1;M2=O59;F2=1;M2=1;M2


    • sen kirjoitti:

      Itse tein vastaavan niin että päivä piti katkaista keskiyöllä, eli alkuvuoro erikseen ja loppuvuoro erikseen. Oma järki ei riittänyt yhteen lausekkeeseen. Tuo ensimmäinen ongelmahan olisi ihan - laskua:
      loppuaika-alkuaika= B1-A1 (ruudussa C1)
      C1-10 (ruudussa D1)ja saat vastaukseksi 100%tunnit
      D1-C1 (ruudussa F1) ja saat vastaukseksi 50% tunnit
      C1-D1-F1 ja tulee se 0% tunnit.
      Tämä nyt vain ihan selvyyden vuoksi ettei aina tarvi kauheita kaavoja.

      Omassa tunti-ilmoituspohjassa yölisät erotellaan aktiiveista näin (yötä aamulla ja illalla, 24h vuorot); =JOS(JA(E2>=O59;E2P59;M2>=1;M2=O59;F2=1;M2=1;M2

      Ei toimi nuo kaavat kun vuorokausi vaihtuu työssäolo aikana.
      Esimerkki.
      Töihintulo solussa A1 14:00.
      Töistälähtö solussa B1 06:00.
      Soluun C1 kaava =B1-A1 antaa risuaitaa.
      Samoin käy soluun soluun D1 kaavalla = C1-10

      Vuorotunti kaavaa en ymmärrä ollenkaan???
      Voisitko selventää?


    • Prosessimies kirjoitti:

      Nuohan toimii vaikka vuorokausi vaihtuu työvuoron aikana , mutta miten sais laskettua iltavuoro- ja yövuorotunnit jos iltatunnit 14:00-22:00 ja yötunnit 22:00- 06:00.

      Jos käytetään apuna noita kaavoja jotka annoin tämän keskustelun aloittajalle.
      Iltatunnit soluun I4 kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>7/12;C422/24;22/24;E4 C4)-JOS(C422/24;C430/24;30/24;E4 C4)-JOS(C4


    • paavali50 kirjoitti:

      Jos käytetään apuna noita kaavoja jotka annoin tämän keskustelun aloittajalle.
      Iltatunnit soluun I4 kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>7/12;C422/24;22/24;E4 C4)-JOS(C422/24;C430/24;30/24;E4 C4)-JOS(C4

      Hyvin toimii, kiitoksia paljon.


    • Olen yrittänyt tehdä työajanseurantaa excelillä, mutta ei oikein onnistu.
      Voinko laittaa tekeleeni sulle sähköpostina, jos keksisit ratkaisun pulmiini.


    • Hoitsu. kirjoitti:

      Olen yrittänyt tehdä työajanseurantaa excelillä, mutta ei oikein onnistu.
      Voinko laittaa tekeleeni sulle sähköpostina, jos keksisit ratkaisun pulmiini.

      Lähetä vain, niin katellaan.

      paavali50@suomi24.fi


    • paavali50 kirjoitti:

      Jos käytetään apuna noita kaavoja jotka annoin tämän keskustelun aloittajalle.
      Iltatunnit soluun I4 kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>7/12;C422/24;22/24;E4 C4)-JOS(C422/24;C430/24;30/24;E4 C4)-JOS(C4

      Hei
      Millainen kaava tulisi jos iltatyö alkaisi 18.00 ja loppuisi 22.00.
      Yötyö klo 22.00 ja loppuisi 07.00


    • taulukon värkkääjä kirjoitti:

      Hei
      Millainen kaava tulisi jos iltatyö alkaisi 18.00 ja loppuisi 22.00.
      Yötyö klo 22.00 ja loppuisi 07.00

      Jos käytetään apuna noita samoja soluja kuin edellisessä niin soluun I4 iltatunnit kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>9/12;C422/24;22/24;E4 C4)-JOS(C422/24;C431/24;31/24;E4 C4)-JOS(C4


    • paavali50 kirjoitti:

      Jos käytetään apuna noita samoja soluja kuin edellisessä niin soluun I4 iltatunnit kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>9/12;C422/24;22/24;E4 C4)-JOS(C422/24;C431/24;31/24;E4 C4)-JOS(C4

      Suurkiitokset,toimi hyvin. Teen työvuorolaskenta taulukkoa KVTES- sopimuksessa ja vuorotyötä tekeville. Kunhan aikaa on niin jatkan ja tarvitsisin vielä apua. Pitää vielä saada laskemaan lauantai, sunnuntai ja ehkä ( aattotyö)
      Saako kysellä kaavan muodostamisesta ? Kokeilen vielä itse, mutta jos ei onnistu niin tarvin varmaan vähän apuja. Olet kyllä tosi taitava noiden kaavojen kanssa.


    • taulukon värkkääjä kirjoitti:

      Suurkiitokset,toimi hyvin. Teen työvuorolaskenta taulukkoa KVTES- sopimuksessa ja vuorotyötä tekeville. Kunhan aikaa on niin jatkan ja tarvitsisin vielä apua. Pitää vielä saada laskemaan lauantai, sunnuntai ja ehkä ( aattotyö)
      Saako kysellä kaavan muodostamisesta ? Kokeilen vielä itse, mutta jos ei onnistu niin tarvin varmaan vähän apuja. Olet kyllä tosi taitava noiden kaavojen kanssa.

      Kyllä voit kysellä, autan jos pystyn.
      paavali50@suomi24.fi


    • elikkä muuten hyvä mutta ruokatunti olis hyvä saada pois työajasta.
      t.Rane


    • Rane kirjoitti:

      elikkä muuten hyvä mutta ruokatunti olis hyvä saada pois työajasta.
      t.Rane

      =(JOS(D4="";"";D4-C4 (D4


    • paavali50 kirjoitti:

      Jos käytetään apuna noita kaavoja jotka annoin tämän keskustelun aloittajalle.
      Iltatunnit soluun I4 kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>7/12;C422/24;22/24;E4 C4)-JOS(C422/24;C430/24;30/24;E4 C4)-JOS(C4

      tehdä kaavat kun:

      työt alkoi olis ruudussa B5
      työt loppui ruudussa B6

      eli iltavuoro 18-22 ja yövuoro 22-06

      Mites saa sit viikkotunnit laskettua yhteensä, mieluiten ihan tavan tollikan ymmärrettävä vastaus... =)


    • paavali50 kirjoitti:

      Jos käytetään apuna noita samoja soluja kuin edellisessä niin soluun I4 iltatunnit kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>9/12;C422/24;22/24;E4 C4)-JOS(C422/24;C431/24;31/24;E4 C4)-JOS(C4

      Saisks vielä apua ko hommaan.
      Jos iltatunnit onklo 18-21 ja yö 21-06


    • vetonit kirjoitti:

      Saisks vielä apua ko hommaan.
      Jos iltatunnit onklo 18-21 ja yö 21-06

      Minulla ei ole Exceliä tällä koneella, ja on pari vuotta kun nuo kaavat tein.
      Mutta kokeileppa noita, jos ei toimi niin parannellaan kun palaan omalle koneelle.
      Iltatunnit:
      =JOS(E4="";"";JOS(JA(C4 E4>9/12;C421/24;21/24;E4 C4)-JOS(C421/24;C430/24;30/24;E4 C4)-JOS(C4


    • paavali50 kirjoitti:

      Jos käytetään apuna noita kaavoja jotka annoin tämän keskustelun aloittajalle.
      Iltatunnit soluun I4 kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>7/12;C422/24;22/24;E4 C4)-JOS(C422/24;C430/24;30/24;E4 C4)-JOS(C4

      Kaava toimii hyvin, muuuttta ei se vieläkään riitä.

      """""Jos käytetään apuna noita kaavoja jotka annoin tämän keskustelun aloittajalle.
      Iltatunnit soluun I4 kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>7/12;C422/24;22/24;E4 C4)-JOS(C422/24;C430/24;30/24;E4 C4)-JOS(C4


    • Yksi rivi työaikalistaltani. Tässä olen lisännyt Paavalin kaavaan vähennyslaskun joka vähentää tehdyistä tunneista 7,5 h päältä.

      =JOS(D20="";"";JOS(D20


    • pg_giraffe kirjoitti:

      Kaava toimii hyvin, muuuttta ei se vieläkään riitä.

      """""Jos käytetään apuna noita kaavoja jotka annoin tämän keskustelun aloittajalle.
      Iltatunnit soluun I4 kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>7/12;C422/24;22/24;E4 C4)-JOS(C422/24;C430/24;30/24;E4 C4)-JOS(C4

      Mitä "";"" tarkoittaa noissa paavali50:n kaavoissa?


    • paavali50 kirjoitti:

      Jos käytetään apuna noita kaavoja jotka annoin tämän keskustelun aloittajalle.
      Iltatunnit soluun I4 kaavalla
      =JOS(E4="";"";JOS(JA(C4 E4>7/12;C422/24;22/24;E4 C4)-JOS(C422/24;C430/24;30/24;E4 C4)-JOS(C4

      Hei! Millaiselta yötunnit-kaavan pitäisi näyttää, jos on työvuorolistassa on tarkoituskin katkaista vuoro klo 24? Eli jos yövuoro sattuu olemaan 22:00 - 07:00, niin 2 tuntia siitä tulee edellisen vuorokauden yötunneiksi ja 7 tuntia seuraavan vuorokauden yötunneiksi?


    • Excel-aloittelija kirjoitti:

      Mitä "";"" tarkoittaa noissa paavali50:n kaavoissa?

      ""- merkki tarkoittaa tyhjää solua, eli jos tuo yllä esimerkkinä:
      =JOS(E4="";"" . Lue :(JOS(E4 on tyhjä, niin jätä vastaussolu silloin myös tyhjäksi...)
      Kun kaava kopioidaan alaspäin valmiiksi odottamaan seuraavia työpäiviä jää vastaussolu tyhjäksi kunnes ko. päivän tulo ja lähtöaika on merkattu.


  • olisi tarve seuraavaan

    Pystysarakkeen C tehtävä olisi esittää siihen kirjattu kellonaika muodossa 15:00-21:30 (tämä on toki jo tehty), ja sarakkeen D tehtävä olisi näyttää tälle välille jäävä aika muodossa 6.5

    Eli molemmat, alkamis- ja loppumisajat olisivat samassa ruudussa.

    Suur Kiitos!

    • Elikkäs keksin ratkaisun, kaverin avustuksella..

      jätin kaksoispisteet pois ja poimin numerot omiin sarakkeisiinsa, tulostettavan alueen ulkopuolelle. Sitten suoritin niistä lokeroista miinuslaskulla homman kotiin..


  • Hei!
    Edellisessä työpaikassani oli työkaverini tehnyt oikein hyvän excel taulukon mihin piti vain täyttää kellonaika ja taulukko laski automaattisesti sen oletko tehnyt ylitöitä vai plussatunteja!Nyt harmittaa,kun en tajunnut silloin katsoa,että millä kaavoilla hän oli tehnyt sen.Hän oli tehnyt sen kaikille kuukausille.Nyt uudessa paikassa tarvitsisin sellaisen samanlaisen taulukon.

  • Entäs sitten miten tehdään kaava tällaisesta työtunnista?Kellonaika on 11-19 ja siitä tulisi tunti iltatöitä(klo 18-19).Haluaisin sellaisen taulukon mihin tarvitsisi vain täyttää kellonaika ja laskuri laskisi kaiken muun automaattisesti itse.

  • voiko tuon ruokatunnin poistamisen ja työtunnit kaavat jotenkin yhdistää?

    • Entäs päivät kun ei tehdä töitä`?millä kaavalla se tehdään?


  • Saakos tätä Exceliä laskemaan ihan normaalisti ilman mitää yölisiä tunnit Esim 21:00 - 03:00

  • =B9 (B8>B9)-B8

    B8 alkaa
    B9 loppuu

    Solun muotoilun pitää olla [TT]:MM eli lisäät vain hakasulkeet

    • Saakos tämän Excelin laskee vajaaksi jääneestä työpäivästä tasoitustunnit. Esim normipäivän pituus 8h, mutta kestää vain 7h jolloin kentään pitäisi saada erotukseksi 1h.


  • Hieno kaava, olen vähän samoilla jäljillä kuin "Tasoittelu"
    eli miten saatais sellainen, jos ja kun viikkotunnit (5x8=40) eivät tule täyteen, silloin ei makseta ylitöistä, elikkä ylitöitä vähennetään sieltä kalleimmasta päästä niin että saadaan joka päivälle 8 h.
    Menikö sekavaksi..

  • Hei osaatteko auttaa tälläisessa ongelmassa?

    Eli jouduin muuttamaan asetuksista päivämäärälaskennaks 1904 - järjestelmän, jotta saan negatiivisiä aikoja. Mutta sitten en voi käyttää kaavaa viikonpäivä(xx), koska näyttää päivät päin honkia.

    Joten joudun käyttämään seuraavanlaista kuin =PÄIVÄYS(2012;1;1) ja seuraavaan soluun C17 1 -> C18 1 jne.

    Mutta nyt en saa millään ilveellä muotoiltua tuolta ehdollisella muotoilulla vain viikonlopun päivien rivit.

  • Olen edellä mainitusti tehnyt kaavat joidenka mukaan työpäivästä eritellään 6-18 välinen työaika (ns normaali tuntiliksa) 18-24 välinen työaika (iltatyö) sekä 24-06 välinen työaika (yötyö).

    Nyt näitä monistamalla on saatu koko viikko tehtyä eli jokainen päivä on ns erikseen merkitty.

    Miten lasketaan koko viikon normaalit työtunnit sekä ilta että yötyötunnit yhteen kaavoista suoraan? Kun kelloja käytetään niin kun tulee yli 24h täyteen nollaantuu kello niinsanotusti eli ei tule tunteja kuten esim 68:10:00

  • Jos tuntimäärä menee yli 24h, pitää summasolu muotoilla muotoon [t]:mm

  • Hei!
    Lasken tässä parasta aikaa odotusaikoja työhön liittyen.Työssäni pitää laskea se,että paljonko kuorma tuli myöhässä. Esim. jos työaika alkoi 2.08 mutta kuorma tuli vasta 3.40 niin siitähän tulee 1:32 odotusta. Miten saisi excelin muuttamaan 1:32 suoraan minuuteiksi?Kokeilin jo tuota minuutti kaavaa,mutta se laskee sen väärin!Se laskee sen 32 minuutiksi mikä ei pidä paikkaansa,kun kyseessä on tunti 32 minuuttia. Pitääkö solu muuttaa tekstiksi vai miten?Olen käyttänyt 2.08 ja 3.08 soluissa t:mm:ss muotoilua.Kiitän kovasti avusta!

    • oma solumuotoilu [mjavascript:void(0);m]


    • kunde kirjoitti:

      oma solumuotoilu [mjavascript:void(0);m]

      hakasulkujen väliin 2 mm kirjainta siis...


  • ööh...siis mihin tuo 2 mm ja [mjavascript:void(0);m] pitää laittaa?suoraan soluun vai?Näytä esimerkillä!Mitä kaavaa käytit?

  • Eli siis tarkennuksena tarkoitan siis sitä,että jos 1:32 (tunti 32 minuuttia)pitäisi saada minuutti muotoon niin tuleeko tuo kaava näin [mjavascript:void(F56);m] vai?Toi F56 on siis solunnimi....Ei muuten toimi tuo kaava tässä excelissä....

  • [mm]

  • Miten tosta [mm] sitten tehdään kaava?sori kun jankkaan....

  • Se oli tarkoitettu muotoiluosastolle.

    Mutta sitä ei tarvitse jos laittaa kaavan F6*24*60

  • hei kiitti!

  • =JOS(E4="";"";JOS(E4>10/24;1/12;JOS(E4>1/3;E4-1/3;"")))

    Mikä tähän täytyy muuttaa jos haluaa, että ylityöt ruvetaan laskemaan 7,5h päivän jälkeen? Koittanu pähkäillä noita jakajia mutta en saa päähäni mistä nuo tulee.

    Kun tuolla kaavalla ylityölaskuri rupeaa toimimaan vasta kun työaika ylittää 8h ja näin ei omalla alalla ole.

    Mutta muuten kyllä erittäin toimiva kaava.

    Esim. miksi 10/24 ja 1/12 sekä 1/3?

  • Aikalaskut Excelillä ovat aika "konstikkaita". En tiedä ovatko nämä minun ohjeeni ihan kaikkien sääntöjen mukaisia, mutta ainakin pelaa. Siis noita edellä olevia soluarvoja käyttäen: Kaikissa soluissa solumuotoilu t:mm, jos tunnit menee yli 24h niin käytä [t]:mm
    E4=JOS(D4="";"";D4-C4 (D47,5/24;7,5/24;E4)) - näyttää "normaalitunnit", sinulla 7:30
    G4=JOS(E4="";"";JOS(E4>9,5/24;1/12;JOS(E4>7,5/24;E4-7,5/24;""))) - näyttää 50% tunnit (eli jos tunnit on yli 9,5h vastaus on 2:00h (1/12) ja loput menee 100%
    H4=JOS(E4="";"";JOS(E4 >9,5/24;E4-9,5/24;"")) - näyttää 100% tunnit (eli yli 2h menevät ylityöt)
    Tässä käytetään murtolukuja "tunteina", koska Excelin kaavoihin ei voi laittaa suoraan kellonaikoja, esim. että =JOS(E4>7:30;.....,
    10/24 = 10h
    1/12 = 2h
    1/48=0:30h eli 1/24=1h ja 1/48=0:30h
    Puolitunteja (esim 7,5) voi myös käyttää (ainakin minä)

  • Tuohon E4 kaavan on näköjään iskenyt "painovirhepaholainen" eli
    E4=JOS(D4="";"";JOS(E4>7,5/24;7,5/24;E4))
    Tämä kaava näyttää siis päivän "normituntimäärän" eli sinulla vain 7,5h asti. Vaikka tunteja olisikin yli tuon määrän näkyy tässä siis vain 7,5h ja loput menevät ylityötunteihin (G4 ja H4 kaavoihin)
    Jos haluat ensin nähdä kaikki päivän tunnit, niin sitten
    =JOS(D4="";"";JOS(D4

    • Kiitos erittäin paljon! Vähän muokkasin omaan käyttöön sopivaksi. Kiitos ja kumarrus!


  • Hei.

    Nyt tarttis jonkun viisaan jeesiä probleemaan. Meillä on VPK.ssa käytössä muualta saatu excel pohja jota tarttis vähän vielä kehittää, että saataisiin siitä vielä yksinkertaisempi ja helpompi käyttää niille jotka eivät tietokoneita pahemmin ole tottuneet käyttämään.

    - Pitäisi saada tunnit laskettua jokaiselta alkavalta puolelta tunnilta.
    - Pitäisi osata laskea ilta ja yö-lisät ja ylityöt automaattisesti, jokaisen puolentunnin täyttymisen jälkeen. (ilta 18-22 & yö 22-06) (ylityöt 8< 50%, 10

    • Sen verran selkeytän vielä että:

      Esim: alkoi 16:12 Päättyi 23:27

      tulos olis:
      Tunnit 7.5 h
      ilta 4 h
      Yö 1.5 h


  • Näillä alkuun....
    A B C D E F
    1 Alkoi Loppui Aika Normi Ilta Yö
    2 5:12 23:38 18:26 12:00 5:00 1:26

    Kaavat:
    C2 =B2-A2 (A2>B2)

    D2 =(A2>B2)*MEDIAANI(0;B2-6/24;12/24) MAKS(0;MIN(18/24;B2 (A2>B2))-MAKS(6/24;A2))

    E2 =(A2>B2)*MEDIAANI(0;B2-18/24;6/24) MAKS(0;MIN(23/24;B2 (A2>B2))-MAKS(18/24;A2))

    F2 =C2-D2-E2

  • Excelin kanssa tapellaan täälläkin. Työn alla kunta-alan tuntityöläisen ylityökaavake, jossa ei siis tarvitse laskea normaalia työaikaa. Taulukostani löytyy jo töihintulo- ja töistälähtöajat sekä työn kesto. Millaisella kaavalla saadaan laskettua 2 ensimmäistä ylityötuntia 50 %:n ylityökorvauksella ja 2h:n ylimenevät tunnit 100 %:n ylityökorvauksella?

    • Vajaa vuorokausi myöhemmin yllä mainitsemani pulma on selätetty ja taulukko on lähes valmis. Vielä on kuitenkin ongelmia lauantain ylitöiden kaavoissa: lauantain ylityö alkaa vasta klo 07:00 ja 5 ensimmäistä tuntia on 50 % ylityötä. Tällä hetkellä minulla on solussa kaava =JOS(F17>5;5;F17), joka siis laskee 5 ensimmäistä ylityötuntia, josta 50 % lauantaikorvaus. Saan kaavan toimimaan vain, kun solun muotoilu on "Yleinen" ja työtunnit desimaalilukuna. Osaako joku kertoa, miten soluun saisi ehdon, että lauantain ylityöt lasketaan vasta klo 07:00 alkaen? Vai onko se ylipäänsä mahdollista?


    • Excel-aloittelija kirjoitti:

      Vajaa vuorokausi myöhemmin yllä mainitsemani pulma on selätetty ja taulukko on lähes valmis. Vielä on kuitenkin ongelmia lauantain ylitöiden kaavoissa: lauantain ylityö alkaa vasta klo 07:00 ja 5 ensimmäistä tuntia on 50 % ylityötä. Tällä hetkellä minulla on solussa kaava =JOS(F17>5;5;F17), joka siis laskee 5 ensimmäistä ylityötuntia, josta 50 % lauantaikorvaus. Saan kaavan toimimaan vain, kun solun muotoilu on "Yleinen" ja työtunnit desimaalilukuna. Osaako joku kertoa, miten soluun saisi ehdon, että lauantain ylityöt lasketaan vasta klo 07:00 alkaen? Vai onko se ylipäänsä mahdollista?

      Yleisesti ylitöistä, minulla oli:
      -Normaali työ 7,5h, päivittäinen ylityö alkoi 8h jälkeen.
      -Viikko ylityö alkoi 40h jälkeen ,esim. lauantaina
      -Sunnuntain korvaus vaihteli sen mukaan oliko lauantaina töissä vai ei.
      -Ylityövuorokauden vaihtuminen ei aina ollut 24:00.

      Luo jokaiselle ylityö% oma sarake tai rivi. Jos työn päättymisaika on lauantaina klo 11:30 niin se on suurempi kuin lauantaina klo 7:00, Excel osaa tehdä vertailun oikein
      If ja AND funktioilla saat nuo 50% ja 100% , ... tunnit eriteltyä


    • jkhgte4 kirjoitti:

      Yleisesti ylitöistä, minulla oli:
      -Normaali työ 7,5h, päivittäinen ylityö alkoi 8h jälkeen.
      -Viikko ylityö alkoi 40h jälkeen ,esim. lauantaina
      -Sunnuntain korvaus vaihteli sen mukaan oliko lauantaina töissä vai ei.
      -Ylityövuorokauden vaihtuminen ei aina ollut 24:00.

      Luo jokaiselle ylityö% oma sarake tai rivi. Jos työn päättymisaika on lauantaina klo 11:30 niin se on suurempi kuin lauantaina klo 7:00, Excel osaa tehdä vertailun oikein
      If ja AND funktioilla saat nuo 50% ja 100% , ... tunnit eriteltyä

      Ongelmani on siis se, että yritin tehdä JA-funktiolla soluun ehdon, että työtunnit lasketaan lauantaina vasta klo 7:00 alkaen ja ensimmäiset 5 tuntia on 50 % ylityötä. Kun edellä mainittu ehto on [t:mm] muodossa ja jälkimmäinen ei, niin homma ei pelitä.


  • Moi, Haluaisin tehdä sarakkaaen joka näyttää /- tunnit jokaiselta päivältä mutta kuukauden tulevat päivät nollanna kunnes ollaan sihen päivään tultu. Nyt on käytössä kaava jossa saan näkyviin vai plussa tunnit. Osaako joku auttaa ja saanko lähettää taulukon sille?

  • Pystyisikö joku antamaan Excel kaavat seuraavalle:

    Solussa C4 töihin tuloaika
    Solussa D4 töistä lähtöaika
    Soluun E4 työtunnit 06-18
    Soluun F4 Työtunnit 18-22
    Soluun G4 Työtunnit 22-06

    • E4 =MAX( IF(C4>=D4;"18:00";MIN("18:00"; D4) ) - MAX("06:00";C4); 0)*24
      F4 =MAX( IF(C4>=D4;"22:00";MIN("22:00"; D4)) - MAX("18:00";C4); 0)*24
      G4 =(D4-C4+ IF(C4>=D4; 1; 0))*24 -E4 -F4


    • Soluun tulee virhe #NIMI?


    • Janne307 kirjoitti:

      Soluun tulee virhe #NIMI?

      Voi olla että MAX- ja IF-funktiot pitää vaihtaa suomenkielisiksi.

      MAX -> MAKS
      IF -> JOS


    • Sain toimimaan osittain. Saako muutettua niin, että, jos tulo- ja lähtöaika on tyhjiä, niin myös kaavasolut näyttäisivät nollaa tai olisivat tyhjiä.
      Ongelmana on se, että, jos esim. työ alkaa 17:30 ja päättyy aamulla 7:30. Alkuun tulee 0:30 6-18, sen jälkeen 4:00 18-22 ja 8:00 22-06 ja vielä 1:30 6-18.
      Ei näyttäisi toimivan näillä kaavoilla.
      Mahtaako löytyä kaavoja, joilla tämän saisi toimimaan näin?


  • Tämän ketjun alkupuolella työajan laskentaan on paavali50 laittanu joitakin kaavoja.

    paavali50 postaus ko. kohdasta

    Solussa C4 töihin tuloaika
    Solussa D4 töistä lähtöaika
    Soluun E4 lasketaan tunnit kaavalla:
    =JOS(D4="";"";JOS(D410/24;1/12;JOS(E4>1/3;E4-1/3;"")))

    Soluun H4 100% tunnit: =JOS
    (E4="";"";JOS(E4 >10/24;E4-10/24;""))

    Kaikissa näissä soluissa muotoiluna Oma [t]mm

    Ketjussa myöhemmin esitetään kaavat iltatyö (18:00-22:00) ja yötyö (22:00-07:00), mutta nuo kaavat ovat "katkenneet"

    Jos käytetään apuna noita samoja soluja kuin edellisessä niin soluun I4 iltatunnit kaavalla
    =JOS(E4="";"";JOS(JA(C4 E4>9/12;C422/24;22/24;E4 C4)-JOS(C422/24;C431/24;31/24;E4 C4)-JOS(C4

    Joten voisiko paavali50 tai joku, jolla ne on tai osaa väsätä ne, laittaa tänne saataville. Kiitos

    • Tuloaika Lähtöaika Työtunnit 06-18 Työtunnit 18-22 Työtunnit 22-06
      7:00 20:00 11 2 0
      6:00 22:00 12 4 0
      22:00 7:00 0 0 9
      6:00 14:00 8 0 0
      14:00 22:00 4 4 0
      22:00 6:00 0 0 8

      Solusta A2 lähtee 7:00 (muotoilu "aika")
      Solu C2 on (muoiluna "luku")
      kaavat:
      C2 = MAKS( JOS(A2>=B2;"18:00";MIN("18:00"; B2) ) - MAKS("06:00";A2); 0)*24
      D2 =MAKS(JOS(A2>=B2;"22:00";MIN("22:00"; B2))-MAKS("18:00";A2); 0)*24
      E2 =(B2-A2+JOS(A2>=B2; 1;0))*24 -C2 -D2
      Apu kaipaan seuraaviin.

      Miten saada :
      Tuloaika Lähtöaika Työtunnit 06-18 Työtunnit 18-22 Työtunnit 22-06
      22:00 7:00 0 0 9

      22:00- 7:00 jaksolta tulee Työtunnit 22-06 välille 9h vaikka pitäisi saada 8 ja viimeinen 1h tunti 6:00 - 7:00 pitää saada Työtunnit 06-18 1h jaksolle.

      F2 = Kaava ruokatunnista 30 min vähennys, jos yli 6h päivä.

      Kiitos avusta


Ketjusta on poistettu 0 sääntöjenvastaista viestiä.