Ö ja Ä ei toimi

Freebsd10.1

Näppäistö näyttää olevan suomalaisella layoutilla, mutta kun painaa ä- ja ö-kirjainta tulee komentoriville vain numerot 366 ja 344. Puuttuuko multa jotkut fontit vai mikä vika? Ja tämä ongelma esiintyy vain kun on fyysisesti koneella. ssh:n kautta skandit toimii.

4

<50

Vastaukset

  • Näillä toimii ääkköset minulla FreeBSD 10.1:ssä

    - konsoli:

    editoi kotihakemistossasi oleva .login_conf-tiedosto muotoon

    me:\
    :charset=iso-8859-1:\
    :lang=fi_FI.ISO8859-1:

    kirjaudu uudelleen sisään niin pitäisi toimia

    - graafinen käyttöliittymä (X11)

    luo /etc/X11/xorg.conf.d-hakemistoon tiedosto 10-input.conf, jonka sisältö on

    Section "InputClass"
    Identifier "Keyboard Defaults"
    Driver "keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "fi"
    Option "XkbOptions" "terminate:ctrl_alt_bksp"
    EndSection

    Section "InputClass"
    Identifier "Mouse Defaults"
    Driver "mouse"
    MatchIsPointer "on"

    • hups, tuohon loppuun kuuluu vielä EndSection, siis uudelleen X11-osuus

      Section "InputClass"
      Identifier "Keyboard Defaults"
      Driver "keyboard"
      MatchIsKeyboard "on"
      Option "XkbLayout" "fi"
      Option "XkbOptions" "terminate:ctrl_alt_bksp"
      EndSection

      Section "InputClass"
      Identifier "Mouse Defaults"
      Driver "mouse"
      MatchIsPointer "on"
      EndSection


  • Ja vielä lisäys: /boot/loader.conf-tiedostossa rivi

    kern.vty=vt

  • Näinhän siinä käy kun ei osaa erottaa fyysistä näppäimistöä ja käyttöjärjestelmän näppäinasetuksia.
    Muuta ihmeessä ne näppäinasetukset oikeaksi. (minulla on latin-1 fi asetus)

Ketjusta on poistettu 2 sääntöjenvastaista viestiä.