Yhteenlasku

arijukka.makitalo

Minulla on A1-A5 sarakkeessa luvut 5,7,99,44 ja 12. B1-B5 sarakkeessa luvut 90,12,6,99 ja 9. C-sarakkeessa kaava =indeksi($a$1:$a$5;vastine($b1;$a$1:$a$5;0)), joka ilmoittaa että luvut 12 ja 99 on B-sarakkeessa. Mtenkä saan summattua luvut B-sarakkeesta ilman että tarvitsee laittaa B-sarakkeeseen luvut jotka löytyy A-sarakkeesta, summa(12;99). Se onnistuu käsipelin kun lukuja on muutama. Mutta entäs jos lukuja onkin A ja B-sarakkeessa vaikka 100. Lukujen etsiminen tuottaa melkoisen etsimisen. Onko tuollaisen funktion teko mahdollista? Vastauksesta kiittäen. Ari

2

524

    Vastaukset

    Anonyymi (Kirjaudu / Rekisteröidy)
    5000
    • Anonyymi

      Laita johonkin soluun

      =SUM(IFERROR(C:C;0))

      Älä paina pelkkää enteriä lopuksi, vaan ctrl+shit+enter. Funktion ympärille pitäisi tulla silloin kaarisulut {=SUM(IFERROR(C:C;0))}.

      Ja muuta tietysti tarvittaessa funktioiden nimet suomenkielisiksi.

    • Anonyymi

      Tarkoitit varmaankin että yhteenlasku ilman C-sarakkeen kaavoja. Exelillä onnistuu ainakin näin:
      =SUMMA(JOS(ONLUKU(VASTINE(B1:B5;A1:A5;0));B1:B5)) - matriisikaava (ctrl+shift+enter)

      tai sitten tavallisella kaavalla
      =TULOJEN.SUMMA(ONLUKU(VASTINE(B1:B5;A1:A5;0))*B1:B5)

    Ketjusta on poistettu 0 sääntöjenvastaista viestiä.

    Luetuimmat keskustelut

    1. Seiska: Sofia Belorf haki terapeutilta apua - Avautuu Stefan Thermanista: "Räjähdysherkkä ilotulite"

      Sofia Belórf avautuu miesystäviensä Stefan Thermanin ja Niko Ranta-ahon yhteisistä piirteistä Seiskalle. Therman heitti Sofian tavarat ulos ikkunasta
      Kotimaiset julkkisjuorut
      54
      2212
    2. Raju tilitys Stefan T, nyt aloitti Sofia haukkumiset ja käy terapiassa.

      Siitä nähtiin taas, Sofia alkoi heti syyttelyt ja kaikki kertonut Seiskassa,ei osannut tätäkään nainen pitää suutaan kiinni erosta.
      Kotimaiset julkkisjuorut
      361
      1965
    3. Sofia ilmestyi eilen illalla instaansa, on silmät surulliset ja koko kasvojen olemus .

      Ei ole koskaan helppoa eroa olemassa, vaikka kuinka sitä toisin jotkut väittävät.
      Kotimaiset julkkisjuorut
      58
      1419
    4. Voitko kertoa rakas

      mikä sen muutoksen sinussa aiheutti?
      Ikävä
      116
      1174
    5. Marin jälleen poliittisia irtopisteitä keräämässä, matkusti Ukrainaan

      Saamme varmasti kuvasarjoja liikuttuneesta Marinista itkemässä ja surkuttelemasta ukrainalaisia. Loistava tilaisuus taas kerätä itselleen
      Maailman menoa
      370
      829
    6. Varoituksen sana

      Älkää satuttako sitä ihmistä ketä rakastatte. Jos niin teette, edessä on katumuksen täyteinen pitkä yksinäisyys. Itsellä se varmaan jatkuu koko loppue
      Ikävä
      67
      732
    7. Mies eikä me voitas nähdä

      viikonloppuna? :) ai niin ootko muuten varattu?
      Ikävä
      108
      703
    8. Tampereen sanna lähti lomalle Ukrainaan

      Suomessakin olisi asioita hoidettavana, ja siellä vaan ulkomailla patsastelee. Milloin on seuraavat eduskuntavaalit? Valtion velkaantumisen on loputt
      Tampere
      205
      692
    9. Tekis mieli kertoa

      Miten pahalta tää on tuntunut ja mitä mietin mut en uskalla ottaa riskiä että sattuu vaan yhä enemmän. Ei näille tunteille voi mitään. Olisin vaan toi
      Ikävä
      28
      684
    Aihe