Monimutkainen JOS-funktio?

Anonyymi

Osaisikohan kukaan guru avustaa miestä mäessä...

Olen tekemässä excelillä pisteytys-kaavaketta. Minun pitäisi saada yhteen soluun tietty pistearvo (0,1,2,3) sen perusteella, mitä toiseen soluun syötetään.

Osa on hyvin simppeleitä, mutta viidessä muuttujassa on se "ongelma", että niissä on melko paljon mahdollisia arvoja. Esimerkkinä arvo 8 tai alle tuottaa 3 pistettä, arvo 9 ja 11 väliltä tuottaa 1 pisteen, arvo 12 ja 20 väliltä tuottaa 0 pistettä, arvo väliltä 21-24 tuottaa 2 pistettä ja 25 tai yli tuottaa 3 pistettä. Näitä missä on 5 mahdollista "arvoryhmää" on pari noista, yhdessä on kuusi ja yhdessä 4.

JOS-funktio toimi tiettyyn rajaan saakka mutta loppui sitten. JOS.JOUKKO sen sijaan ei toiminut ollenkaan (johtuuko versiosta ?)

Miten saisin tämän aikaiseksi. Excelini on suomenkielinen 2016.

6

<50

Vastaukset

  • Mikä se JOS -lause oli mikä toimi johonkin asti ja sitten lopetti toiminnan?

    • No nyt en enää tiedä koska sen menin poistamaan. Se toimi tuossa esimerkkini tapauksessa aina arvoon 20 asti ja lopetti siihen. Olisikohan ongelmakohta ollut JOS(B3>=21;”2”;JOS(B3<=24;"2";

      Muistaakseni korjasin tuon vielä niin että kukin mahdollisista arvoista (21,22,23,24) oli omana funktionaan ja viimeinen arvo (25 tai yli) oli JOS(B3>=25;”3”; eikä se silti toiminut.


    • Anonyymi kirjoitti:

      No nyt en enää tiedä koska sen menin poistamaan. Se toimi tuossa esimerkkini tapauksessa aina arvoon 20 asti ja lopetti siihen. Olisikohan ongelmakohta ollut JOS(B3>=21;”2”;JOS(B3<=24;"2";

      Muistaakseni korjasin tuon vielä niin että kukin mahdollisista arvoista (21,22,23,24) oli omana funktionaan ja viimeinen arvo (25 tai yli) oli JOS(B3>=25;”3”; eikä se silti toiminut.

      =IF(OR(B3<=8;B3>=25);3; IF(AND(B3>=21;B3<=24);2;IF(AND(B3>=9;B3<=11);1; 0)))


  • Tässä tapauksessa lienee helpoin tehdä kahden sarakkeen taulukko, jossa vasemmassa on hakuarvo ja oikeassa haun tulos. Sitten vaan PHAKU-funktiolla haetaan tulos.

  • Leikitään esimerkiksi seuraavaa:

    Luodaan ensin arvotaulukko soluihin C1:D18
    C1=8 ja D1=3
    C2=9 ja D2=1
    C3=10 ja D3=1
    C4=11 ja D4=1
    C5=12 ja D5=0
    C6=13 ja D6=0
    C7=14 ja D7=0
    C8=15 ja D8=0
    C9=16 ja D9=0
    C10=17 ja D10=0
    C11=18 ja D11=0
    C12=19 ja D12=0
    C13=20 ja D13=0
    C14=21 ja D14=2
    C15=22 ja D15=2
    C16=23 ja D16=2
    C17=24 ja D17=2
    C18=25 ja D18=3

    Maalataan alue C1:D18 ja komennetaan Kaavat/Määritä nimi
    Uusi nimi/Nimi -kenttään kirjoitetaan: arvot (OK)

    Oletetaan, että solun A1 arvo riippuu edellä olevan taulukon mukaan siitä mikä on solun B1 arvo. Soluun A1 kirjoitetaan kaava:

    =JOS(B1<9;PHAKU(8;arvot;2);JOS(B1>24;PHAKU(25;arvot;2);PHAKU(B1;arvot;2)))

    Nyt vaihtamalla arvoa solussa B1 vaihdat samalla automaattisesti arvoa myös solussa A1.

  • =OR(J1<=8;J1=25)*3+AND(J1<=11;J1>=9)*1+AND(J1<=24;J1>=21)*2

    Keep EXCELing
    @Kunde

Ketjusta on poistettu 0 sääntöjenvastaista viestiä.