JOS ja työaikapankki

Anonyymi

Uudessa työpaikassa ei ole työajanseurantaan ohjelmaa, ja ajattelin vähemmän näppäränä tyttönä tehdää Exceliin kaavat sitä varten. Saan yksittäiset asiat toimimaan, mutta en osaa niitä yhdistää.

C3 = tuloaika
D3 = lähtöaika
E3 = lounasaika (0:30)
G3 = kokonaistyöaika
H3 = normaalityöaika 0 % (7,5 h, kun lounas laskettu pois, tai mikäli jää alle 7,5, niin sitten se)

Sitten kuitenkin haluaisin laskea pankkitunnit =
+ ylityötunnit (mikäli päivän työaika ylittää normaalityöajan 7,5h)
- miinustunnit (mikäli alle 7,5h)

ja tämän kaiken vielä haluaisin niin, että päivän kohdalla näytetään laskelma vain, jos päivän kohdalle on merkitty työaikaan jotain.

6

<50

Vastaukset

  • Ruutupaperi ja lyijykynä. Kelpaa myös oikeudessa mahdollisissa riitatilanteissa.

  • Siitä vaan nikkaroimaan. Onhan tuo tehtävissä. Tosin itse laiskana ihmisenä laittaisin tiedot tietokantaan, koska taulukoiden nysvääminen ja ylläpito on melko työlästä.

    • Onko M-Karista tullut laiskakin?


    • Minä en viitsisi edes tietokantoja nyysvätä, tekisin Lazaruksella ohjelman tuohon.


    • Anonyymi kirjoitti:

      Onko M-Karista tullut laiskakin?

      Mikä tuo on? Tietokantaan vaan timestampit alku- ja loppuajoista. Kyselyllä kokonaisaika ja halutessa tarvittavat vähennykset ja/tai kertoimet.


  • G3=JOS(D3="";"";D3-C3)- kokonaistyöaika - vastaus näkyy vasta kun lähtöaika on annettu (D3)
    H3=JOS(D3="";"";(D3-C3)-E3) - tehokas työaika (-lounas)
    Excelillä aikalaskenta on hyvin "hankalaa" jos pitää laskea "aliaikoja", koska Excel ei osaa laskea negatiivisia aikoja, mutta ainahan voi ajat muuttaa desimaalimuotoon
    G3=JOS(D3="";"";D3-C3)*24 - nyt aika näkyy desimaalimuodossa (esim 7,5) ja vähennys/yhteenlasku onnistuu. Solumuotoilu "Luku" tai "Yleinen" ja tarvittava määrä desimaaleja.

suomi24-logo

Osallistu keskusteluun

Ketjusta on poistettu 0 sääntöjenvastaista viestiä.

Luetuimmat keskustelut

  1. En ymmärrä holokaustin kieltäjiä?

    Aivan sama kuin kieltäisi ettei 2 maailmansotaa ole ollutkaan. Onko heillä pimeä alue tuolta osin vai onko se tahallista kieltämistä. Jos myöntäisi se
    Maailman menoa
    314
    2832