Aihe

Pysyykö apt-mark holdit holdissa unholdiin saakka?

Anonyymi

Haluan estää kernelin päivittymisen ajamalla apt-mark holdin linux-genericille, linux-image-genericille ja linux-headers-genericille.

Päivitän muut paketit apt upgradella.

Kun kernelistä tulee tarjolle seuraavan kerran uudemmat versiot, niin pitääkö apt-mark hold ajaa uudelleen apt updaten jälkeen ennen apt upgradea, vai säilyykö hold kunnes unholdataan paketit?

Noissa kernelin paketeissahan ei ole mitään versionumeroita mukana.

23

<50

    Vastaukset

    Anonyymi (Kirjaudu / Rekisteröidy)
    5000
    • Anonyymi

      Ubuntua en nyt muista mutta kyllä ainakin Fedora, CentOS ja Arch Linux versionumeroi kernel-paketit...

      • Anonyymi

        Mutta pitääkö hold kaikki versiot holdissa? Kun nyt esim. showhold näyttää

        $ apt-mark showhold
        linux-generic
        linux-headers-generic
        linux-image-generic

        Eli pysyykö nuo holdit voimassa unholdiin saakka, vaikka tulisi uudempia versioitakin? Ettei vahingossa jonkun upgraden yhteydessä alkaisi asentamaan kerneleitäkin.


      • Anonyymi
        Anonyymi kirjoitti:

        Mutta pitääkö hold kaikki versiot holdissa? Kun nyt esim. showhold näyttää

        $ apt-mark showhold
        linux-generic
        linux-headers-generic
        linux-image-generic

        Eli pysyykö nuo holdit voimassa unholdiin saakka, vaikka tulisi uudempia versioitakin? Ettei vahingossa jonkun upgraden yhteydessä alkaisi asentamaan kerneleitäkin.

        MIKSI uutta kerneliä ei saisi tai tulisi asentaa, MIKSI?


      • Anonyymi
        Anonyymi kirjoitti:

        MIKSI uutta kerneliä ei saisi tai tulisi asentaa, MIKSI?

        Kone ei toimi uudemmilla kerneleillä.


      • Anonyymi
        Anonyymi kirjoitti:

        Kone ei toimi uudemmilla kerneleillä.

        Älä sitten päivitä sitä enää ikinä.


      • Anonyymi
        Anonyymi kirjoitti:

        Älä sitten päivitä sitä enää ikinä.

        Totta kai päivitän. Lopeta sinä näillä palstoilla kiukuttelu.


    • Anonyymi

      apt-mark holdit saattaa pysyä, mutta ohjelmat päivittyy silti, mutta ethän sinä sitä kysynytkään.

    • Anonyymi

      hold
      hold is used to mark a package as held back, which will prevent the
      package from being automatically installed, upgraded or removed.

      Siinäpä se.

      • Anonyymi

        Siltähen se äkisti vaikuttaa. Mutta jos jotain asettaa apt-get pakettihallinassa pitoon, ei se estä muita pakettihallinta ohjelmia tekemästä päivitystä, esim. aptitude pakettihalinta käyttää omaa erillistä asetustiedostoa. Entä:

        sudo apt-get install (estetty)
        entä
        sudo dpkg -i
        entä
        sudo snap install
        entä
        sudo apt install
        entä
        AppImage
        entä
        flatpak
        entä
        Itse käännetyt lähdekoodipaketit
        entä
        Synaptic-pakettienhallinta

        On siinä niin monta muttaa että käyttäjän täytyy sitoutua yhteen pakettihallintaan, varmistaakseen pidon säilymisen.


      • Anonyymi
        Anonyymi kirjoitti:

        Siltähen se äkisti vaikuttaa. Mutta jos jotain asettaa apt-get pakettihallinassa pitoon, ei se estä muita pakettihallinta ohjelmia tekemästä päivitystä, esim. aptitude pakettihalinta käyttää omaa erillistä asetustiedostoa. Entä:

        sudo apt-get install (estetty)
        entä
        sudo dpkg -i
        entä
        sudo snap install
        entä
        sudo apt install
        entä
        AppImage
        entä
        flatpak
        entä
        Itse käännetyt lähdekoodipaketit
        entä
        Synaptic-pakettienhallinta

        On siinä niin monta muttaa että käyttäjän täytyy sitoutua yhteen pakettihallintaan, varmistaakseen pidon säilymisen.

        Asiat on niin mustavalkeilta ja yksinkertaisia, kun tietoa on vähän tai ei ollenkaan.


      • Anonyymi
        Anonyymi kirjoitti:

        Siltähen se äkisti vaikuttaa. Mutta jos jotain asettaa apt-get pakettihallinassa pitoon, ei se estä muita pakettihallinta ohjelmia tekemästä päivitystä, esim. aptitude pakettihalinta käyttää omaa erillistä asetustiedostoa. Entä:

        sudo apt-get install (estetty)
        entä
        sudo dpkg -i
        entä
        sudo snap install
        entä
        sudo apt install
        entä
        AppImage
        entä
        flatpak
        entä
        Itse käännetyt lähdekoodipaketit
        entä
        Synaptic-pakettienhallinta

        On siinä niin monta muttaa että käyttäjän täytyy sitoutua yhteen pakettihallintaan, varmistaakseen pidon säilymisen.

        Siis ööh... Ei ole olemassa mitään erillistä apt-get -paketinhallintaa, apt -paketinhallintaa, Synaptic -paketinhallintaa jne. Apt, apt-get, aptitude, Synaptic ja dpkg ovat kaikki käyttöliittymiä Debianin paketinhhallinnalle. Eli kyllä apt-mark -komennolla pitoon asetettu paketti on pidossa ihan yhtälailla apt, apt-get tai Synaptic jne paketinhallintatyökaluja käytettäessä.

        apt-mark -komennolla asetetaan paketteja pitoon Debianin paketinhallinnassa, sillä asetetaan pitoon Debianin paketinhallinnan kautta asennettavia Debian -paketteja,. Joten apt-mark -komennolla pitoon laitetut paketit ei tietenkään liity mitenkään flatpakiin, snapiin, appimg:n jne. Eihän niillä ole mitään tekemistä Debianin paketinhallinnan kanssa. Eli on ihan älytöntä, että edes listaat noita tässä yhteydessä. Samaten, jos asennat ohjelman paketinhallinnan ohi lähdekoodeista kääntämällä, niin se ei tietenkään myöskään liity mitenkään tuohon.

        Eikö tuon nyt pitäisi olla itsestäänselvää jo apt-mark -komennon nimen perusteella? Ei siinä komennon nimessä turhaan ole merkkijonoa apt, vaan sen takia että kyseessä on Debianin paketinhallintaan liittyvä työkalu.

        Kyllä apt-mark -komennolla pitoon laitetut paketit on pidossa myös esimerkiksi Synapticia käytettäessä, mutta itseasaissa Synapticilla voidaan tehdä myös pelkästään Synapticia koskevia pitoon laittamisia. Eli, jos halutaan laittaa paketti pitoon niin, että se on pidossa sekä komentoriviltä käytettäviä paketinhallintatyökaluja, että Synapticia käytettäessä, niin sillon pitoon laitto pitää tehdä komentoriviltä, ei siis Synapticista käsin.


      • Anonyymi
        Anonyymi kirjoitti:

        Siltähen se äkisti vaikuttaa. Mutta jos jotain asettaa apt-get pakettihallinassa pitoon, ei se estä muita pakettihallinta ohjelmia tekemästä päivitystä, esim. aptitude pakettihalinta käyttää omaa erillistä asetustiedostoa. Entä:

        sudo apt-get install (estetty)
        entä
        sudo dpkg -i
        entä
        sudo snap install
        entä
        sudo apt install
        entä
        AppImage
        entä
        flatpak
        entä
        Itse käännetyt lähdekoodipaketit
        entä
        Synaptic-pakettienhallinta

        On siinä niin monta muttaa että käyttäjän täytyy sitoutua yhteen pakettihallintaan, varmistaakseen pidon säilymisen.

        Näin se on, tuosta pitkästä listasta puuttui, ehkä eniten käytetty vaihtoehto "Sovellusvalikoima" -työkalu jolla ohjelmia asennellaan graafisesti.

        Kuten edellä jo mainittiin, yksikään asennustyökalu ei tarkastele toisen asennustyökalun pitoon asettamisia, vaan toimivat itsenäisesti toisistaan riippumatta.

        Joten pidossa pysyminen yhden asennustyökalun asettamana, on hyvin epävarmaa, mikäli käyttää sekaisin useampaa asentamisen mahdollistavaa ohjelmaa.


      • Anonyymi
        Anonyymi kirjoitti:

        Näin se on, tuosta pitkästä listasta puuttui, ehkä eniten käytetty vaihtoehto "Sovellusvalikoima" -työkalu jolla ohjelmia asennellaan graafisesti.

        Kuten edellä jo mainittiin, yksikään asennustyökalu ei tarkastele toisen asennustyökalun pitoon asettamisia, vaan toimivat itsenäisesti toisistaan riippumatta.

        Joten pidossa pysyminen yhden asennustyökalun asettamana, on hyvin epävarmaa, mikäli käyttää sekaisin useampaa asentamisen mahdollistavaa ohjelmaa.

        Itse asiassa, epäilen että pitoon asettaminen toimii vain järjestelmän ylläpitämissä päivitystapahtumissa ja näin ollen se ei estä minkään ohjelmien asennus työkalujen toimintaa.

        Tämä oli, MUTUA, ei varmaa tietoa.


    • Anonyymi

      Kyllä apt-mark -työkalulla pitoon laitetut paketit pysyy pidossa kunnes otat ne pois pidosta. Jos haluat laittaa pitoon tietyn version, tai tietyt versiot, jostain paketista, niin sen voi tehdä myöskin. Se tehdään tosin luomalla asetustiedosto /etc/apt/preferences.d -hakemistoon. Jos tuo kiinnostaa niin voit hakea netistä tietoa Debianin -paketinhallinnan APT pinning -ominaisuudesta.

      Niin ja vaikka paketin nimessä ei olisi versionumeroa osana paketin nimeä, niin se ei tietenkään tarkoita sitä, että paketilla ei olisi versionumeroa. Tottakai jokaisella paketilla on versionumero.

      T. miksuh

      • Anonyymi

        "Jos tuo kiinnostaa niin voit hakea netistä tietoa Debianin -paketinhallinnan APT pinning -ominaisuudesta."

        Voit olla ihan varma ettei vähempää voisi moiset Debianit kiinnostaa.


      • Anonyymi
        Anonyymi kirjoitti:

        "Jos tuo kiinnostaa niin voit hakea netistä tietoa Debianin -paketinhallinnan APT pinning -ominaisuudesta."

        Voit olla ihan varma ettei vähempää voisi moiset Debianit kiinnostaa.

        Kyllä minua ainakin kiinnostaa, miksi sua ei kiinnosta? oletko joku windowsnisti vai?


      • Anonyymi
        Anonyymi kirjoitti:

        Kyllä minua ainakin kiinnostaa, miksi sua ei kiinnosta? oletko joku windowsnisti vai?

        Minulla kun ei ole peltoa, en tee paskallakaan mitään.


      • Anonyymi
        Anonyymi kirjoitti:

        Minulla kun ei ole peltoa, en tee paskallakaan mitään.

        Taitaa kuitenkin olla sitä korviesi välissä.


      • Anonyymi
        Anonyymi kirjoitti:

        Kyllä minua ainakin kiinnostaa, miksi sua ei kiinnosta? oletko joku windowsnisti vai?

        No se on täysin sinun oma ongelmasi. Et ilmeisesti ymmärrä sitä, että Ubuntu perustuu Debianin kehitysversioon joten Ubuntu myös käyttää Debianin paketinhallintaa ja Debianin paketinhallintatyökaluja. Miten sitten ylipäätänsä käytät sitä apt-mark -työkalua kun se on Debianin paketinhallintatyökalu?

        T. miksuh


      • Anonyymi
        Anonyymi kirjoitti:

        No se on täysin sinun oma ongelmasi. Et ilmeisesti ymmärrä sitä, että Ubuntu perustuu Debianin kehitysversioon joten Ubuntu myös käyttää Debianin paketinhallintaa ja Debianin paketinhallintatyökaluja. Miten sitten ylipäätänsä käytät sitä apt-mark -työkalua kun se on Debianin paketinhallintatyökalu?

        T. miksuh

        Tuo olis siis vastaus tyypille, joka sanoi ettei Debian kiinnosta. Jos ei ohjeet kelpaa niin omapa on ongelmansa.

        T. miksuh


      • Anonyymi
        Anonyymi kirjoitti:

        No se on täysin sinun oma ongelmasi. Et ilmeisesti ymmärrä sitä, että Ubuntu perustuu Debianin kehitysversioon joten Ubuntu myös käyttää Debianin paketinhallintaa ja Debianin paketinhallintatyökaluja. Miten sitten ylipäätänsä käytät sitä apt-mark -työkalua kun se on Debianin paketinhallintatyökalu?

        T. miksuh

        Taisit vastailla väärälle ihmiselle, minä nimittäin TIEDÄN että niin Ubuntu kuin Linux Minttikin perustuu Debianiin ja minua olisi kyllä kiinnostanut tuo debian-asia!


      • Anonyymi
        Anonyymi kirjoitti:

        Tuo olis siis vastaus tyypille, joka sanoi ettei Debian kiinnosta. Jos ei ohjeet kelpaa niin omapa on ongelmansa.

        T. miksuh

        VASTAUS 1
        "Kyllä minua ainakin kiinnostaa, miksi sua ei kiinnosta? oletko joku windowsnisti vai?"

        En käytä huumausaineita.

        VASTAUS 2
        "Taitaa kuitenkin olla sitä korviesi välissä."

        Minullla ei ole paskaa korvien välissä.

        VASTAUS 3
        "No se on täysin sinun oma ongelmasi."

        Minulla ei ole ongelmia siksi etten käytä Debiania, mutta näyttää siltä että suomi24 keskustelupastalla joudun haukutuksi sen vuoksi.

        VASTAUS 4
        "Miten sitten ylipäätänsä käytät sitä apt-mark -työkalua"

        En käytä apt-mark -työkalua.

        Hirveätä Debianin tyrkyttämistä. MINÄ EN ASENNA DEBIANIA IKINÄ, onko selvä.


      • Anonyymi
        Anonyymi kirjoitti:

        VASTAUS 1
        "Kyllä minua ainakin kiinnostaa, miksi sua ei kiinnosta? oletko joku windowsnisti vai?"

        En käytä huumausaineita.

        VASTAUS 2
        "Taitaa kuitenkin olla sitä korviesi välissä."

        Minullla ei ole paskaa korvien välissä.

        VASTAUS 3
        "No se on täysin sinun oma ongelmasi."

        Minulla ei ole ongelmia siksi etten käytä Debiania, mutta näyttää siltä että suomi24 keskustelupastalla joudun haukutuksi sen vuoksi.

        VASTAUS 4
        "Miten sitten ylipäätänsä käytät sitä apt-mark -työkalua"

        En käytä apt-mark -työkalua.

        Hirveätä Debianin tyrkyttämistä. MINÄ EN ASENNA DEBIANIA IKINÄ, onko selvä.

        No mitäs v*ttua sitten tröllaat täällä jos kerran käytät vain witutin 10:ä ja olet kiinnostunut vain siitä?


    Ketjusta on poistettu 1 sääntöjenvastaista viestiä.

    Luetuimmat keskustelut

    1. Halla-aho: Emme halua, että punavihreä hallitus jatkaa

      https://www.is.fi/politiikka/art-2000007761119.html Alkaa olla nykyhallituksella lopun ajat.
      Maailman menoa
      361
      4278
    2. Miksi Helmi ja Julia haluavat lehden kanteen?

      Itseään paljon vanhemman miehen kanssa? Dannyn ”tyttöystävä” Helmi Herra Ylpön ”tyttöystävä” Julia. Onhan näitä ollut kautta aikain. Muutama vuosi kun
      Kotimaiset julkkisjuorut
      57
      3188
    3. Torppa Levillä

      Mites se raskauspahoinvointi ??
      Kotimaiset julkkisjuorut
      90
      1709