Debian 11.1.0 ja Thunderbird

Anonyymi

Moikka!

Mulla on asennettuna Debian 11.1.0 Mate työpöydällä. Kun yritän asentaa Thunderbirdin niin vaatii libbotan kirjastoa. Jonka onnistuin lataamaan deb pakettina. Se taas vaatii libtspil (<=0.3.1) kirjastoa jota yritin hakea mutta ei löytynyt. Ymmärtääkseni liittyy TPM:ään (tässä koneessa TMP 1.2 aktivoituna).
Mistähän tuo löytäisi? Vai onko jokin muu keino asenttaa se?

73

1398

    Vastaukset

    Anonyymi (Kirjaudu / Rekisteröidy)
    5000
    • Anonyymi

      Latasitko Debianin omasta pakettivarastosta?
      Jos, niin silloin tuon libin pitäisi asentua thunderbirdin mukana. Ohjelma ilmoittaa myös tarvittavien osien lisäyksestä ennen latausta.
      Jos et niin on parasta ensin etsiä Debin omasta varastosta.
      Voit tietysti etsiä sitä kirjastoa nimellä myös erikseen Debianin pakettilähteestä.

      • Anonyymi

        O.K. Kiitos! En ladannut koitin asentaa sudo apt install ja hakea Synoptic-paketinhallinasta. Ensimmäisen hain .deb pakettina. Kun yritän asentaa tuo .deb kirjaston vaatii ainakin vielä tuota toista...


      • Anonyymi
        Anonyymi kirjoitti:

        O.K. Kiitos! En ladannut koitin asentaa sudo apt install ja hakea Synoptic-paketinhallinasta. Ensimmäisen hain .deb pakettina. Kun yritän asentaa tuo .deb kirjaston vaatii ainakin vielä tuota toista...

        Tarkotit varmaankin Thunderbirdin asentamista pakettivarastosta :) Heh! Tulee virheilmoitus jostin puuttuvista riippuvuuksista?


      • Anonyymi kirjoitti:

        O.K. Kiitos! En ladannut koitin asentaa sudo apt install ja hakea Synoptic-paketinhallinasta. Ensimmäisen hain .deb pakettina. Kun yritän asentaa tuo .deb kirjaston vaatii ainakin vielä tuota toista...

        Siis tarkoitatko että "sudo apt install thunderbird" ei toimi?

        Kyllä tuo minulla ainakin toimii (Debian 11).


      • Anonyymi
        Anonyymi kirjoitti:

        O.K. Kiitos! En ladannut koitin asentaa sudo apt install ja hakea Synoptic-paketinhallinasta. Ensimmäisen hain .deb pakettina. Kun yritän asentaa tuo .deb kirjaston vaatii ainakin vielä tuota toista...

        Debianissa ei sudotella. Roottina loitsutaan komento
        apt install thunderbird
        ja apt hoitaa kaiken.


      • Anonyymi
        malaire kirjoitti:

        Siis tarkoitatko että "sudo apt install thunderbird" ei toimi?

        Kyllä tuo minulla ainakin toimii (Debian 11).

        Kyllä! Tulee valitusta puuttuvista riippuvaisuus-suhteista!


      • Anonyymi
        Anonyymi kirjoitti:

        Debianissa ei sudotella. Roottina loitsutaan komento
        apt install thunderbird
        ja apt hoitaa kaiken.

        Kuten edelliseen viestiin vastasin :(


      • Anonyymi kirjoitti:

        Kyllä! Tulee valitusta puuttuvista riippuvaisuus-suhteista!

        Mitkä .deb paketit olet nyt ladannut ja asentanut itse? Kerro myös tarkat versiot.

        Jos olet asentanut jonkun väärän version niin tuo saattaa sotkea paketinhallintaa.


      • Anonyymi
        Anonyymi kirjoitti:

        O.K. Kiitos! En ladannut koitin asentaa sudo apt install ja hakea Synoptic-paketinhallinasta. Ensimmäisen hain .deb pakettina. Kun yritän asentaa tuo .deb kirjaston vaatii ainakin vielä tuota toista...

        Älä latile mitään paketteja käsin mistään vaan asenna Thunderbird suoraan Debianin ohjelmalähteistä siten kuin annoin sulle ohjeen toisessa viestissäni.

        T. miksuh


      • Anonyymi
        Anonyymi kirjoitti:

        Tarkotit varmaankin Thunderbirdin asentamista pakettivarastosta :) Heh! Tulee virheilmoitus jostin puuttuvista riippuvuuksista?

        Jos Thunderbird asennetaan Debianin omista ohjelmalähteistä niin sillon ei kyllä tule yhtään mitään ilmotuksia puuttuviksista riippuvuuksista.

        T. miksuh


      • Anonyymi
        Anonyymi kirjoitti:

        Kyllä! Tulee valitusta puuttuvista riippuvaisuus-suhteista!

        Eikä varmasti tule,jos asennat sen Debianin ohjelmalähteistä. Sulla on jotain pielessä käyttiksen ohjelmalähdeasetuksissa jos noin käy.

        Itselläni on käytössä Debian11 "Bullseye" ja Thunderbird on asennettuna Debianin omista ohjelmalähteistä.

        T. miksuh


      • Anonyymi
        Anonyymi kirjoitti:

        Älä latile mitään paketteja käsin mistään vaan asenna Thunderbird suoraan Debianin ohjelmalähteistä siten kuin annoin sulle ohjeen toisessa viestissäni.

        T. miksuh

        Lähde mun mukaan
        Mä vien sut nyt museoon
        Tahdon siellä näyttää sulle entisajan sähköpostinkäyttöä!

        Se on nostalgista!
        Se on mennyttä aikaa!
        Tahtoisin että muutkin sen ymmärtäisi!

        Tervetuloa, ovet on avoinna
        Sähköposti-ohjelmamuseoon!
        On lupa katsella, on lupa muistella!
        Mutta ei kannata ottaa sähköpostiohjelmaa käyttöön, se kuuluu museoon!

        Vanhoja sähköpostiohjelmia, epäkäytännöllisineen toimintoineen ja
        muinaisjäänteitä, tuoksuja kaukaa
        Vuosien takaa!

        Tunnetko vielä sen
        nostalgisen hengityksen kiihtyneen
        Ja rinnan alla ärtymyksen, koska hankala käyttää!


      • Anonyymi
        Anonyymi kirjoitti:

        Lähde mun mukaan
        Mä vien sut nyt museoon
        Tahdon siellä näyttää sulle entisajan sähköpostinkäyttöä!

        Se on nostalgista!
        Se on mennyttä aikaa!
        Tahtoisin että muutkin sen ymmärtäisi!

        Tervetuloa, ovet on avoinna
        Sähköposti-ohjelmamuseoon!
        On lupa katsella, on lupa muistella!
        Mutta ei kannata ottaa sähköpostiohjelmaa käyttöön, se kuuluu museoon!

        Vanhoja sähköpostiohjelmia, epäkäytännöllisineen toimintoineen ja
        muinaisjäänteitä, tuoksuja kaukaa
        Vuosien takaa!

        Tunnetko vielä sen
        nostalgisen hengityksen kiihtyneen
        Ja rinnan alla ärtymyksen, koska hankala käyttää!

        Vaivaako noin kovin kun suosikkileffasi "Yö museossa" ei ole muutamaan viikkoon tullut telkkarista?
        Vaikka telkkari taitaa olla sullen liian vanha keksintö.


      • Anonyymi
        Anonyymi kirjoitti:

        Älä latile mitään paketteja käsin mistään vaan asenna Thunderbird suoraan Debianin ohjelmalähteistä siten kuin annoin sulle ohjeen toisessa viestissäni.

        T. miksuh

        Ei toiminut tuossa jostain syystä? Nyt päivittelin levyn käyttöjärjestelmiä niin Debian 11.1.0 Gnome työpöydällä toimii apt install thunderbird ja lataa nuo riippuvuudet automaattisesti. Pitää vielä testata paketinhallinnasta (Synaptic). On muuten tässä Gnome versiossa vakiona Evolution...


      • Anonyymi
        Anonyymi kirjoitti:

        Lähde mun mukaan
        Mä vien sut nyt museoon
        Tahdon siellä näyttää sulle entisajan sähköpostinkäyttöä!

        Se on nostalgista!
        Se on mennyttä aikaa!
        Tahtoisin että muutkin sen ymmärtäisi!

        Tervetuloa, ovet on avoinna
        Sähköposti-ohjelmamuseoon!
        On lupa katsella, on lupa muistella!
        Mutta ei kannata ottaa sähköpostiohjelmaa käyttöön, se kuuluu museoon!

        Vanhoja sähköpostiohjelmia, epäkäytännöllisineen toimintoineen ja
        muinaisjäänteitä, tuoksuja kaukaa
        Vuosien takaa!

        Tunnetko vielä sen
        nostalgisen hengityksen kiihtyneen
        Ja rinnan alla ärtymyksen, koska hankala käyttää!

        Mee nyt j-lauta muualle häiriköimään noine museoviesteines! Sitäpaitsi Thunderbird on NYKYAIKAA JA SELAINPOSTIT ON MENNEISYYTTÄ!


    • Anonyymi
    • > ... vaatii libbotan kirjastoa. Jonka onnistuin lataamaan deb pakettina. Se taas vaatii libtspil (<=0.3.1) kirjastoa jota yritin hakea mutta ei löytynyt.

      Ei noita .deb paketteja kannata itse ladata, asennat vaan Synaptic:ssa paketin "thunderbird" tai vaihtoehtoisesti "sudo apt install thunderbird" ja kummassakin tapauksessa kaikki tarvittavat muut paketit asennetaan automaattisesti.

      Jos jostain syystä haluat asennella manuaalisesti, niin Debian 11:n libbotan-2-17 vaatii libtspi1 (>= 0.3.1) joka löytyy täältä:
      https://packages.debian.org/bullseye/libtspi1

      • Anonyymi

        Loppu hyvin kaikki hyvin! Ratkesi jo ongelma :) Viimeinen keirjain olikin 1 eikä l. Ei ihme ettei löytynyt :) Latasin molemmat .deb paketteina ja asensin ne ja Synaptic-paketinhallinan kautta ilman ongelmia Thunderbirdin (78.14.0). Kiitos vielä avusta!


      • Anonyymi
        Anonyymi kirjoitti:

        Loppu hyvin kaikki hyvin! Ratkesi jo ongelma :) Viimeinen keirjain olikin 1 eikä l. Ei ihme ettei löytynyt :) Latasin molemmat .deb paketteina ja asensin ne ja Synaptic-paketinhallinan kautta ilman ongelmia Thunderbirdin (78.14.0). Kiitos vielä avusta!

        Pitäisko hankkia vahvemmat lasit :) Tässä ei löydy paketinhallinasta kaikkea? Esimerkiksi yritin asentaa Zoomin. Vaikka kuinka paljon riippuvuuksia? Eikä ole yksinkertaisempaa keinoa asentaa riippuvuudet?


      • Anonyymi kirjoitti:

        Pitäisko hankkia vahvemmat lasit :) Tässä ei löydy paketinhallinasta kaikkea? Esimerkiksi yritin asentaa Zoomin. Vaikka kuinka paljon riippuvuuksia? Eikä ole yksinkertaisempaa keinoa asentaa riippuvuudet?

        zoom ei näytä löytyvän Debianin omista paketeista, joten sen asentaminen voi olla hankalampaa.


      • Anonyymi
        malaire kirjoitti:

        zoom ei näytä löytyvän Debianin omista paketeista, joten sen asentaminen voi olla hankalampaa.

        Oikeat Linux distribution sisältää 25 pakettia eri tarpeisiin, miksi käytätte maailman reikäisintä ja puutteellisinta jakelua.


      • Anonyymi
        Anonyymi kirjoitti:

        Oikeat Linux distribution sisältää 25 pakettia eri tarpeisiin, miksi käytätte maailman reikäisintä ja puutteellisinta jakelua.

        Luultavasti tässä on kyse Video Conferencing mahdollistavasta ohjelmasta, jonka ilmainen osuus mahdollistaa:

        - Järjestä videokeskusteluja jopa 100 osallistujan ryhmälle
        - Rajoittamaton ryhmäkokous jopa 40 minuuttia.
        - Rajoittamattomia henkilökohtaisia ​​tapaamisia, 30 tunnin aikarajoitus per kokous
        - Yksityinen ja ryhmäkeskustelu

        Google kääntäjän virheitä, mukana riittävästi.
        Mutta asennukseen tarvitaan vain muutama merkki:

        yay -S --aur zoom;


      • Anonyymi
        Anonyymi kirjoitti:

        Luultavasti tässä on kyse Video Conferencing mahdollistavasta ohjelmasta, jonka ilmainen osuus mahdollistaa:

        - Järjestä videokeskusteluja jopa 100 osallistujan ryhmälle
        - Rajoittamaton ryhmäkokous jopa 40 minuuttia.
        - Rajoittamattomia henkilökohtaisia ​​tapaamisia, 30 tunnin aikarajoitus per kokous
        - Yksityinen ja ryhmäkeskustelu

        Google kääntäjän virheitä, mukana riittävästi.
        Mutta asennukseen tarvitaan vain muutama merkki:

        yay -S --aur zoom;

        Ubuntu perii suuriman osan Debianin haavoittuvuuksista, mutta periikö se myös puutteelliset ohjelmalähteet, eli jos ei ole debianissa ei ole myöskään ubuntussa.


      • Anonyymi
        Anonyymi kirjoitti:

        Pitäisko hankkia vahvemmat lasit :) Tässä ei löydy paketinhallinasta kaikkea? Esimerkiksi yritin asentaa Zoomin. Vaikka kuinka paljon riippuvuuksia? Eikä ole yksinkertaisempaa keinoa asentaa riippuvuudet?

        Näin asennnat Zoomin.
        Hae Zoomin sivulta Debianin paketti.
        Asenna paketti loitsulla
        dpkg -i zoom_amd64.deb
        Asennus keskety puuttuvien pakettien vuoksi.
        Loitsutaan
        apt --fix-broken install
        Apt hakee puuttuvat paketit ja suorittaa zoomin asennuksen loppuun.
        Valmis


      • Anonyymi
        Anonyymi kirjoitti:

        Oikeat Linux distribution sisältää 25 pakettia eri tarpeisiin, miksi käytätte maailman reikäisintä ja puutteellisinta jakelua.

        25 pakettia on kovin vähän. Siinä "väärässä" Debianissa on 60000 pakettia.


      • Anonyymi
        Anonyymi kirjoitti:

        25 pakettia on kovin vähän. Siinä "väärässä" Debianissa on 60000 pakettia.

        Miksi se sitten ei toimi, tai miksi sitää
        - zoom Video Conferencing and Web Conferencing Service
        - zoomx Screen magnifying zoom utility for X11
        - zoom-system-qt Video Conferencing and Web Conferencing Service system Qt libraries
        - zoom-libnimf Nimf library for zoom multilingual input.


      • Anonyymi
        Anonyymi kirjoitti:

        25 pakettia on kovin vähän. Siinä "väärässä" Debianissa on 60000 pakettia.

        Painoin vahingossa lähetä painiketta, kun tarkoitus oli luetella ne 25 zoom pakettia, jos jollekkin pelkkä nimen kertominen olisi antanut käsityksen mistä ohjelmasta olisi kyse.

        Kolme noista 25 zoom paketista asensin ja poistin, siivosin roskat. Kaikki toimivat, tilejä en tehnyt eikä zoomx joka oli näytön suurennoslasi tiliä olisi tarvinnutkaan.

        Nyt kerkisi mieli muuttua en jatka listan tekemistä turhaan, koska vaikutat rollilta tai muuten vähän hölmöltä kaverilta joka ei kuitenkaan ymmärtäisi listan päälle mitään.


      • Anonyymi
        Anonyymi kirjoitti:

        Ubuntu perii suuriman osan Debianin haavoittuvuuksista, mutta periikö se myös puutteelliset ohjelmalähteet, eli jos ei ole debianissa ei ole myöskään ubuntussa.

        n. 74 000 pakettia Ubuntussa. Debianissa on n. 51 000 pakettia. En nyt osaa sanoa, onko luvussa mukana multiverse-paketit mutta universe nyt ainakin, koska en pääse antamaan 'apt list | nl' komentoa juuri nyt missään Debianiin. Ubuntun luvussa taas on mukana myös joitakin yksittäisiä pakettilähteitä - ei kovin monen paketin edestä tosin!


      • Anonyymi
        Anonyymi kirjoitti:

        n. 74 000 pakettia Ubuntussa. Debianissa on n. 51 000 pakettia. En nyt osaa sanoa, onko luvussa mukana multiverse-paketit mutta universe nyt ainakin, koska en pääse antamaan 'apt list | nl' komentoa juuri nyt missään Debianiin. Ubuntun luvussa taas on mukana myös joitakin yksittäisiä pakettilähteitä - ei kovin monen paketin edestä tosin!

        Voi että olet tyhmä sen Debianisi kanssa. Yritätkö uskotella että olet kaikki nuo Debianin paketit asentanut itsellesi.

        LISTAA ASENNETUT PAKETIT
        apt list

        Hönö!


      • Anonyymi kirjoitti:

        Voi että olet tyhmä sen Debianisi kanssa. Yritätkö uskotella että olet kaikki nuo Debianin paketit asentanut itsellesi.

        LISTAA ASENNETUT PAKETIT
        apt list

        Hönö!

        höpöhöhö

        `apt list` listaa kaikki paketit
        `apt list --installed` listaa asennetut paketit

        Minulla on tällä hetkellä 1607 pakettia asennettu ja 59276 pakettia kaikkiaan (tässä on joitakin Debianin ulkopuolisiakin paketteja mukana).


      • Anonyymi
        Anonyymi kirjoitti:

        Näin asennnat Zoomin.
        Hae Zoomin sivulta Debianin paketti.
        Asenna paketti loitsulla
        dpkg -i zoom_amd64.deb
        Asennus keskety puuttuvien pakettien vuoksi.
        Loitsutaan
        apt --fix-broken install
        Apt hakee puuttuvat paketit ja suorittaa zoomin asennuksen loppuun.
        Valmis

        Mulla kun teen noin niin poistaa rikkinäisen paketin??


      • Anonyymi
        Anonyymi kirjoitti:

        Ylläpito on poistanut tästä viestin sääntöjen vastaisena.

        ...jatkuu

        root@envy:~# apt --fix-broken install
        Luetaan pakettiluetteloita... Valmis
        Muodostetaan riippuvuussuhteiden puu... Valmis
        Luetaan tilatiedot... Valmis
        Korjataan riippuvuuksia... Valmis
        The following additional packages will be installed:
        ibus ibus-data ibus-gtk ibus-gtk3 im-config libegl1-mesa libgl1-mesa-glx
        libxcb-xtest0 python3-ibus-1.0
        Ehdotetut paketit:
        ibus-clutter ibus-doc
        Seuraavat UUDET paketit asennetaan:
        ibus ibus-data ibus-gtk ibus-gtk3 im-config libegl1-mesa libgl1-mesa-glx
        libxcb-xtest0 python3-ibus-1.0
        0 päivitetty, 9 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.
        1 ei asennettu kokonaan tai poistettiin.
        Noudettavaa arkistoa 7 286 kt.
        Toiminnon jälkeen käytetään 61,6 M t lisää levytilaa.
        Haluatko jatkaa? [K/e]
        Nouda:1 http://deb.debian.org/debian bullseye/main amd64 libgl1-mesa-glx amd64 20.3.5-1 [51,1 kB]
        Nouda:2 http://deb.debian.org/debian bullseye/main amd64 libegl1-mesa amd64 20.3.5-1 [51,1 kB]
        Nouda:3 http://deb.debian.org/debian bullseye/main amd64 libxcb-xtest0 amd64 1.14-3 [101 kB]
        Nouda:4 http://deb.debian.org/debian bullseye/main amd64 ibus-data all 1.5.23-2 [5 692 kB]
        Nouda:5 http://deb.debian.org/debian bullseye/main amd64 python3-ibus-1.0 all 1.5.23-2 [259 kB]
        Nouda:6 http://deb.debian.org/debian bullseye/main amd64 ibus amd64 1.5.23-2 [547 kB]
        Nouda:7 http://deb.debian.org/debian bullseye/main amd64 ibus-gtk amd64 1.5.23-2 [267 kB]
        Nouda:8 http://deb.debian.org/debian bullseye/main amd64 ibus-gtk3 amd64 1.5.23-2 [267 kB]
        Nouda:9 http://deb.debian.org/debian bullseye/main amd64 im-config all 0.46-1 [52,0 kB]
        Noudettiin 7 286 kt ajassa 1s (9 196 kt/s)
        Selecting previously unselected package libgl1-mesa-glx:amd64.
        (Reading database ... 169358 files and directories currently installed.)
        Preparing to unpack .../0-libgl1-mesa-glx_20.3.5-1_amd64.deb ...
        Unpacking libgl1-mesa-glx:amd64 (20.3.5-1) ...
        Selecting previously unselected package libegl1-mesa:amd64.
        Preparing to unpack .../1-libegl1-mesa_20.3.5-1_amd64.deb ...
        Unpacking libegl1-mesa:amd64 (20.3.5-1) ...
        Selecting previously unselected package libxcb-xtest0:amd64.
        Preparing to unpack .../2-libxcb-xtest0_1.14-3_amd64.deb ...
        Unpacking libxcb-xtest0:amd64 (1.14-3) ...
        Selecting previously unselected package ibus-data.
        Preparing to unpack .../3-ibus-data_1.5.23-2_all.deb ...
        Unpacking ibus-data (1.5.23-2) ...
        Selecting previously unselected package python3-ibus-1.0.
        Preparing to unpack .../4-python3-ibus-1.0_1.5.23-2_all.deb ...
        Unpacking python3-ibus-1.0 (1.5.23-2) ...
        Selecting previously unselected package ibus.
        Preparing to unpack .../5-ibus_1.5.23-2_amd64.deb ...
        Unpacking ibus (1.5.23-2) ...
        Selecting previously unselected package ibus-gtk:amd64.
        Preparing to unpack .../6-ibus-gtk_1.5.23-2_amd64.deb ...
        Unpacking ibus-gtk:amd64 (1.5.23-2) ...
        Selecting previously unselected package ibus-gtk3:amd64.
        Preparing to unpack .../7-ibus-gtk3_1.5.23-2_amd64.deb ...
        Unpacking ibus-gtk3:amd64 (1.5.23-2) ...
        Selecting previously unselected package im-config.
        Preparing to unpack .../8-im-config_0.46-1_all.deb ...
        Unpacking im-config (0.46-1) ...
        Setting up ibus-data (1.5.23-2) ...
        Setting up libegl1-mesa:amd64 (20.3.5-1) ...
        Setting up libxcb-xtest0:amd64 (1.14-3) ...
        Setting up im-config (0.46-1) ...
        Setting up libgl1-mesa-glx:amd64 (20.3.5-1) ...
        Setting up ibus-gtk:amd64 (1.5.23-2) ...
        Setting up python3-ibus-1.0 (1.5.23-2) ...
        Setting up ibus-gtk3:amd64 (1.5.23-2) ...
        Processing triggers for mailcap (3.69) ...
        Processing triggers for desktop-file-utils (0.26-1) ...
        Processing triggers for hicolor-icon-theme (0.17-2) ...
        Processing triggers for gnome-menus (3.36.0-1) ...
        Processing triggers for libglib2.0-0:amd64 (2.66.8-1) ...
        Processing triggers for libgtk-3-0:amd64 (3.24.24-4) ...
        Processing triggers for libgtk2.0-0:amd64 (2.24.33-2) ...
        Processing triggers for libc-bin (2.31-13+deb11u2) ...
        Processing triggers for man-db (2.9.4-2) ...
        Setting up ibus (1.5.23-2) ...
        Setting up zoom (5.8.3.145) ...
        run post install script, action is configure...
        root@envy:~#


      • Anonyymi
        Anonyymi kirjoitti:

        Painoin vahingossa lähetä painiketta, kun tarkoitus oli luetella ne 25 zoom pakettia, jos jollekkin pelkkä nimen kertominen olisi antanut käsityksen mistä ohjelmasta olisi kyse.

        Kolme noista 25 zoom paketista asensin ja poistin, siivosin roskat. Kaikki toimivat, tilejä en tehnyt eikä zoomx joka oli näytön suurennoslasi tiliä olisi tarvinnutkaan.

        Nyt kerkisi mieli muuttua en jatka listan tekemistä turhaan, koska vaikutat rollilta tai muuten vähän hölmöltä kaverilta joka ei kuitenkaan ymmärtäisi listan päälle mitään.

        Debianissa on todellakin yli 60000 ohjelmapakettia tällä hetkellä mikä on paljon enemmän kuin monissa muissa distroissa. Sun olisi kuitenkin syytä ymmärtää, että missään linux -distrossa ei ole maailman kaikkia Linux -ohjelmia. Eli käytät mitä tahansa distroa niin voi olla ettei jotain ohjelmaa löydy suoraan distron ohjelmalähteistä. Sen takia esimerkiki Debianin paketinhallintaan voi lisätä ohjelmalähteitä.

        Sun olisi myös syytä ymmärtää se, että jos asennat distron paketinhallinnan ulkopuolelta jonkin ohjelman, esimerkiksi lataamalla sen käsin jostakinwebbisivulta niin sillon on täysin mahdollista, että kyseinen ohjelma myös vaatii toimiakseen jotain kirjastoja jne, joita ei löydy distron ohjelmalähteistä ja sillon voit joutua asentaamaan myös ne kirjastot jne. Tämä ei koske vain debiania vaan ihan jokaista distroa.

        Yleisesti ikinä ei pitäisi asennella mitään paketinhallinnan ulkopuolelta ellei sitten ole ihan pakko. Tämäkin koskee ihan jokaista distroa. Tuo koskee myös .deb -pakettien lataamista webbisivuilta. Ohjelmia ei kannata latailla edes .deb -paketteina esimerkiksi webbisivuilta ellei ole ihan pakko. Kannattaa myös huomata se, että jos lataat jostain sivulta .deb -paketin niin se voi vaatia kirjastoista jne tietyn version joita ei välttämättä löydy käytössäsi olevasta distrosta, Eli riippuvuusongelma voi syntyä senkin takia, että webbisivulta lataamasi .deb -paketti vaatii toimiakseen eri version jostakin kirjastosta kuin mikä löytyy istrosta. Kannataa huomata, että jostakin webbisivulta lataamasi .deb -paketti ei välttämättä ole yhteensopiva juuri sinun käytössäsi olevan distron kanssa. Ja tämäkään ei koske vain Debiania vaan myös muita distroja.

        Eli älä ikinä asenna mitään paketinhallinnan ohi ellei ole ihn pakko.

        Kannattaa myös huomata, että jos jotakin ohjelmaa ei löydy Debianin omista ohjelmaplähteistä, niin se saattaa löytyä flatpak tai nap -paketoituna. Sekä flatpak, että snap ovat molemmat käytettävissä myös Debianissa.

        Esimerkiksi mainitsemasi Zoom ei löydy Debianin omista ohjelmalähteistä, mutta se on asennettavissa Flatpak -paketoituna käyttämällä latpakia. Debianissa Flatpak ja Snap -paketoidut ohjelmat voi halutessaan saada näkymään myös graafisessa Gnome Software -paketinhallintatyökalussa smaan tapaan kuin Debianin omista ohjelmalähteistä löytyvät ohjelmat.

        T. miksuh
        T. miksuh


      • Anonyymi
        Anonyymi kirjoitti:

        n. 74 000 pakettia Ubuntussa. Debianissa on n. 51 000 pakettia. En nyt osaa sanoa, onko luvussa mukana multiverse-paketit mutta universe nyt ainakin, koska en pääse antamaan 'apt list | nl' komentoa juuri nyt missään Debianiin. Ubuntun luvussa taas on mukana myös joitakin yksittäisiä pakettilähteitä - ei kovin monen paketin edestä tosin!

        Uusimmassa Debian 11 "Bullseye" -versiossa on yli 60000 ohjelmapakettia.

        T. miksuh


      • Anonyymi
        Anonyymi kirjoitti:

        Voi että olet tyhmä sen Debianisi kanssa. Yritätkö uskotella että olet kaikki nuo Debianin paketit asentanut itsellesi.

        LISTAA ASENNETUT PAKETIT
        apt list

        Hönö!

        Jos tässä joku on typerä niin sinä. Eihän kukaaan ole väittänyt, että hänellä olisi asennettuna kaikki _Debianissa olevat ohjelmapaketit, tuskin kenelläkään on. Mutta kyllä Debianissa on nykyisellään yli 6000 ohjelmapakettia saatavilla.

        T. miksuh


      • Anonyymi
        malaire kirjoitti:

        höpöhöhö

        `apt list` listaa kaikki paketit
        `apt list --installed` listaa asennetut paketit

        Minulla on tällä hetkellä 1607 pakettia asennettu ja 59276 pakettia kaikkiaan (tässä on joitakin Debianin ulkopuolisiakin paketteja mukana).

        Komento "apt list" ei listaa asennettuna olevia paketteja vaan kaikki saatavilla olevat paketit. Saat listan asennettuna olevista paketeita komennolla:

        apt list --installed

        T. miksuh


      • Anonyymi kirjoitti:

        Komento "apt list" ei listaa asennettuna olevia paketteja vaan kaikki saatavilla olevat paketit. Saat listan asennettuna olevista paketeita komennolla:

        apt list --installed

        T. miksuh

        No noinhan minä sanoin.


      • Anonyymi
        Anonyymi kirjoitti:

        Pitäisko hankkia vahvemmat lasit :) Tässä ei löydy paketinhallinasta kaikkea? Esimerkiksi yritin asentaa Zoomin. Vaikka kuinka paljon riippuvuuksia? Eikä ole yksinkertaisempaa keinoa asentaa riippuvuudet?

        Zoomin saa asennettua debianiin komennolla:

        flatpak install zoom


      • Anonyymi
        Anonyymi kirjoitti:

        Uusimmassa Debian 11 "Bullseye" -versiossa on yli 60000 ohjelmapakettia.

        T. miksuh

        Tarkoittaako tuo että jokainen noista paketeista on itsenäinen ohjelma? Ei siis mikään data-tiedosto, kielipaketti ym.


    • Anonyymi

      Ei voi muutakuin nauraa. On tämä linulks vaikea. Edes yksinkertaiset asia eivät suju!

      • Anonyymi

        Yksinkertaisen onkin vaikea ymmärtää.


      • Anonyymi

        Ei debian edusta Linuxia, kuin omalta osaltaan, ei pidä yleistää jos yksi on paska, ei kaikki muut ole sitä.


      • Anonyymi
        Anonyymi kirjoitti:

        Yksinkertaisen onkin vaikea ymmärtää.

        No älä sitten vastaa..


      • Anonyymi
        Anonyymi kirjoitti:

        No älä sitten vastaa..

        Mikä kuvaa sinua: yksinkertainen, vaikea vai ymmärtämäön?


      • Anonyymi
        Anonyymi kirjoitti:

        Mikä kuvaa sinua: yksinkertainen, vaikea vai ymmärtämäön?

        Latvastaan laho, on osuva termin sinua kuvaamaan, vai mitä vajakki.


      • Anonyymi
        Anonyymi kirjoitti:

        Latvastaan laho, on osuva termin sinua kuvaamaan, vai mitä vajakki.

        Ottiko noin koville, säälittävää.


      • Anonyymi

        Siksi käytänkin kunnon GNU/Linuxia enkä mitään Microsoftin Linulksia😀


      • Anonyymi
        Anonyymi kirjoitti:

        Ottiko noin koville, säälittävää.

        Niin metsä vastaa, kuin sinne huudetaan.


      • Anonyymi
        Anonyymi kirjoitti:

        Niin metsä vastaa, kuin sinne huudetaan.

        Vaikuttivatkin nuo huutelut menneen metsään, sano.


      • Anonyymi

        Kyllä sujuu jos käyttäjä itse ei sähhlää jotain, sitähän mikään käyttis ei voi estää. Ketjun aloittaj on itse selkeästi sotkenut jotain.


    • Anonyymi

      Asensin virtuaalikoneeseen Debian 11:n net-installerilla, ja siinä tuli automaattisesti Thunderbird mukana.

      $ uname -r
      5.10.0-9-amd64
      $ cat /etc/debian_version
      11.1
      $ thunderbird --version
      Thunderbird 78.14.0

    • Anonyymi

      Mitähän nyt oikein yrität tehdä? Thunderbird löytyy suoraan Debianista itsestään joten ei ole esimerkiksi yhtään mitään tarvetta latailla sitä jostain webbisivuilta jne. Jos käytät Debianissa itsessään olevaa Thunderbirdiä niin mitään tuollaisia riippuvuuksia ei tarvitse selvitelllä eikä mitään kirjastoja jne tarvitse latailla yhtään mistään. Jos asennat Thunderbirdin Debianin ohjelmalähteistä niin samalla asentuu kaikki Thunderbirdin toimiakseen vaatimat kirjastot jne.

      Eli Debianissa Thundderbirdin voi asentaa näin, jos se ei ole jo asennettuna:

      1) Avaa komentorivi-ikkuna

      2) Siirry root -käyttäjäksi komennolla:

      su -

      3) Asenna Thunderbird ja sen suomikielipaketti:

      apt install thunderbird thunderbird-l10n-fi

      Tottakai asenntamisen voi niin halutessaan tehdä myös Debianin graafisilla hiirikäyttöisillä paketinhallintatyökaluilla kuten Synapticilla ja Gnome Softwarella.

      T. miksuh

      • Anonyymi

        Kiitoksia tuosta ohjeesta. Onhan täällä sentään joku, joka kirjottelee asiallisiakin kommentteja.


      • Anonyymi

        Ubuntu onkin toimiva!


    • Anonyymi

      Lähde mun mukaan
      Mä vien sut nyt museoon
      Tahdon siellä näyttää sulle entisajan sähköpostinkäyttöä!

      Se on nostalgista!
      Se on mennyttä aikaa!
      Tahtoisin että muutkin sen ymmärtäisi!

      Tervetuloa, ovet on avoinna
      Sähköposti-ohjelmamuseoon!
      On lupa katsella, on lupa muistella!
      Mutta ei kannata ottaa sähköpostiohjelmaa käyttöön, se kuuluu museoon!

      Vanhoja sähköpostiohjelmia, epäkäytännöllisineen toimintoineen ja
      muinaisjäänteitä, tuoksuja kaukaa
      Vuosien takaa!

      Tunnetko vielä sen
      nostalgisen hengityksen kiihtyneen
      Ja rinnan alla ärtymyksen, koska hankala käyttää!
      s

      • Anonyymi

        Jokos Varpunen on armeijan käynyt? Nehän nykyisin ottaa lättäjälkojakin sinne.


      • Anonyymi

        Runotytönkin olisi syytä joskus kokeilla oikeaa sähköpostiohjelmaa kökköjen selainpostien sijaan.


      • Anonyymi

        Mene nyt o hoitoon, koska selvästi tarvitset sitä.


      • Anonyymi

        Ruppee oleen jo valmis museoon noine juttuineen tuo vapunen.


    • Anonyymi

      Nyt Debian 11.3 Cinnamon työpöydällä :) Asensin ensin kokeeksi MATE työpöydällä! Siinä jotain outoa. Cinnamon työpöydällä asentaa automaatisesti valmiiksi Thunderbirdin ja hoitaa automaatisesti "riippuvuudet" :) MATE:ssa ei!!

      • Anonyymi
        Anonyymi kirjoitti:

        Ylläpito on poistanut tästä viestin sääntöjen vastaisena.

        Ainakin hyvä😀


      • Anonyymi

        Työpöydällä ei ole merkitystä. Kaikkiin työpöytiin tulee paketit samasta paikasta Myös ne työpöydät. Thunderbirdin paketti sisältää tiedon mitä muita se tarvitsee toimiakseen ja apt asentaa ne automaattisesti.


      • Anonyymi
        Anonyymi kirjoitti:

        Työpöydällä ei ole merkitystä. Kaikkiin työpöytiin tulee paketit samasta paikasta Myös ne työpöydät. Thunderbirdin paketti sisältää tiedon mitä muita se tarvitsee toimiakseen ja apt asentaa ne automaattisesti.

        Vaan kun EI tullut MATE työpöydällä??


      • Anonyymi
        Anonyymi kirjoitti:

        Vaan kun EI tullut MATE työpöydällä??

        Miksi työpöydän mukana pitäisi tulla juuri Thunderbird? Debianin oletustyöpöydänkin mukana tulee Evolution sähköpostiohjelma. Thunderbirdin voi sitten asentaa mikäli sen haluaa.


      • Anonyymi
        Anonyymi kirjoitti:

        Vaan kun EI tullut MATE työpöydällä??

        Epäilen että olet käsin yrittänyt asennella niitä paketteja jotka ovat jo Debianissa ja saanut sen sellaiseen tilaan, että pitäisi vaan siivota sotkut pois antaa Debianin itse huolehtia siitä.

        Kokeilin asentaa itse sen Thunderbirdin ja Xfce työpöydällä ja meni ihan heittämällä. Pääkäyttäjänä "apt install thunderbird". En usko, että MATE eroaa tästä millään tavalla.


      • Anonyymi
        Anonyymi kirjoitti:

        Vaan kun EI tullut MATE työpöydällä??

        Palaa wintoosan pariin takaisin. Täällä on jo monesti sinua neuvottu miten thunderbird asennetaan. Et näköjään ymmärrä tai et halua ymmärtää. Debianissa eikä muissakaan linux järjestelmissä EI haeta paketteja mistään netistä. Kaikki ohjelmat Debianissa asennetaan joko graafisesti eli synaptic ohjelmalla tai sitten terminal kautta.


      • Anonyymi
        Anonyymi kirjoitti:

        Palaa wintoosan pariin takaisin. Täällä on jo monesti sinua neuvottu miten thunderbird asennetaan. Et näköjään ymmärrä tai et halua ymmärtää. Debianissa eikä muissakaan linux järjestelmissä EI haeta paketteja mistään netistä. Kaikki ohjelmat Debianissa asennetaan joko graafisesti eli synaptic ohjelmalla tai sitten terminal kautta.

        Opettele lukemaan!! Debian Mate työpöydällä ei onnistu asennus eikä automaattisesti "riippuvuuksien" asennus!!
        Nyt on Debian 11.3.0 Cinnamon työpöydällä joka asensi asennuksessa valmiiksi Thundebirdin 😀 Ohjelmistovarastosta löytyy ohjelmia mitä ei löytynyt MATE työpöydällä esim. vaikka HexChat. Vai toimiiko se muilla??


      • Anonyymi
        Anonyymi kirjoitti:

        Epäilen että olet käsin yrittänyt asennella niitä paketteja jotka ovat jo Debianissa ja saanut sen sellaiseen tilaan, että pitäisi vaan siivota sotkut pois antaa Debianin itse huolehtia siitä.

        Kokeilin asentaa itse sen Thunderbirdin ja Xfce työpöydällä ja meni ihan heittämällä. Pääkäyttäjänä "apt install thunderbird". En usko, että MATE eroaa tästä millään tavalla.

        En vaan asensin Debianin Mate version USB-tikulta. Toisin kun samainen Cinnamon työpöydällä se ei saa asentanut valmiiksi Thunderbirdiä. Eikä saanut asennettua apt install Thunderbird eikä Synapticin kautta. Eikä osaa automaattisesti asentaa "riippuvuuksia"...


      • Anonyymi
        Anonyymi kirjoitti:

        Opettele lukemaan!! Debian Mate työpöydällä ei onnistu asennus eikä automaattisesti "riippuvuuksien" asennus!!
        Nyt on Debian 11.3.0 Cinnamon työpöydällä joka asensi asennuksessa valmiiksi Thundebirdin 😀 Ohjelmistovarastosta löytyy ohjelmia mitä ei löytynyt MATE työpöydällä esim. vaikka HexChat. Vai toimiiko se muilla??

        Tuo nyt ei pidä ollenkaan paikkaansa. Debianin pakettivarasto on täysin sama olkoot se työpöytä mikä hyvänsä ja siellä on samat ohjelmat.

        Mistähän sinä sen Debianin oikein hankit?


      • Anonyymi
        Anonyymi kirjoitti:

        En vaan asensin Debianin Mate version USB-tikulta. Toisin kun samainen Cinnamon työpöydällä se ei saa asentanut valmiiksi Thunderbirdiä. Eikä saanut asennettua apt install Thunderbird eikä Synapticin kautta. Eikä osaa automaattisesti asentaa "riippuvuuksia"...

        Kirjoitit näin:

        " Kun yritän asentaa Thunderbirdin niin vaatii libbotan kirjastoa. Jonka onnistuin lataamaan deb pakettina."

        Tuo on se syy kun olet ilmeisesti hölmönään USB-tikulta asentanut jotain paketteja ja mitä ilmeisimmin sössinyt

        Oliko sinulla edes siinä nettiyhteyttä?


      • Anonyymi
        Anonyymi kirjoitti:

        Kirjoitit näin:

        " Kun yritän asentaa Thunderbirdin niin vaatii libbotan kirjastoa. Jonka onnistuin lataamaan deb pakettina."

        Tuo on se syy kun olet ilmeisesti hölmönään USB-tikulta asentanut jotain paketteja ja mitä ilmeisimmin sössinyt

        Oliko sinulla edes siinä nettiyhteyttä?

        On netti yhteys :) Ihan asentanut USB-tikulta normaalin asennuksen ja valinnut työpöydäksi Maten. Kokeilin Debian 11.3.0 Cinnamonilla asentaa Oracle Virtualboxiin vielä Debian 11.3.0 Mate työpöydällä. Toimi ihan normaalisti eli tunnisti "riippuvuudet" ja asensi Thunderbirdin. Tosin toisin kuin Cinnamonilla jossa Thunderbird asentui perusasennuksessa Matessa ei tullut. Jotain outoa tässä!


      • Anonyymi
        Anonyymi kirjoitti:

        Tuo nyt ei pidä ollenkaan paikkaansa. Debianin pakettivarasto on täysin sama olkoot se työpöytä mikä hyvänsä ja siellä on samat ohjelmat.

        Mistähän sinä sen Debianin oikein hankit?

        Ilmeisesti jotain outoa? Latatasin Debian.org peilipalvelimesta. Debian-11.3.0-amd64-DVD-1.iso...


    • Anonyymi

      Nyt kumminkin mennään Debian 11.3.0 Cinnamon työpöyädällä. Tykkään ehkä enemmän kuin Matesta. Selvittelen mistä tuo johtui? Tähän tyytyväinen :)

    Ketjusta on poistettu 6 sääntöjenvastaista viestiä.

    Luetuimmat keskustelut

    1. Rydman "elämäni hirveimmät päivät" Entäs uhrisi?!

      https://yle.fi/uutiset/3-12515383 Rydman valittelee että vaikeaa on ollut kun jäänyt kiinni mutta entäs uhrisi? Ei yhtään empatiaa uhreja kohtaan!
      Maailman menoa
      289
      4556
    2. Nakkilassa on raiskattu wanhus

      Wanhus on raiskattu nakkilassa palvelutalossa. ( näin uutisoivat molemmat iltapäivälehdet sekä yle )
      Nakkila
      19
      3244
    3. Haluaisin tietää miten sulla menee

      Onko kaikki hyvin? Ja onko sulla yhtään ikävä mua? Itse haluaisin niin kovasti nähdä sut taas :(
      Ikävä
      91
      1386
    4. Totuus on että

      Se kaikki sattui ihan vit**ti koska mä tykkään susta todella paljon. Oikeesti tosi paljon. Menin ihan pois raiteilta enkä tajua tätä itekään. Oon mä j
      Ikävä
      42
      1328
    5. Natoon liittymisen hinta kova.

      Suomi joutuu luovuttamaan kurdeja Turkkiin, maksoiko Suomen Nato-jäsenyys monien kymmenien ihmisten vankeus ja kidutuskohtalon vai peräti kuoleman. ht
      Maailman menoa
      272
      1205
    6. Uskallatko paljastaa

      Kaivattusi nimikirjaimet ja sukupuoli? Minä aloitan, KA, nainen.
      Tunteet
      39
      963
    7. Sofia kertoo et halusi luvan kokeiluihin seksin suhteen Lontoossa asuessaan..

      Katos nainen alkaa kertoa et seksikokeilut alkoi maistua, kun muutti Lontooseen.Marokkolainen räppäri ja tietenkin sekin on varsttu mies ja itse sen k
      Kotimaiset julkkisjuorut
      156
      959
    8. Mikamika missä mika

      Polliisi etsii https://poliisi.fi/-/epailty-henkirikos-torniossa?utm_source=dlvr.it&utm_medium=twitter
      Tornio ja Haaparanta
      7
      886
    9. Aiotko saattaa sen loppuun

      ..mikä on meillä pahasti kesken..ja milloin...en jaksa odottaa enää..
      Ikävä
      54
      864
    10. En halua satuttaa sinua

      Mutta tässä ei ole järkeä!..
      Ikävä
      39
      809
    Aihe