Predict asennus ei onnistu.

$ sudo ./configure
[sudo] password for ate:
Testing compiler...
Testing pthreads library...
Testing ncurses library... /usr/bin/ld: cannot find -lncurses
collect2: error: ld returned 1 exit status

*** Error: Compiler test for ncurses library failed. :-(

$ apt list *ncurses* | grep installed

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libncurses5/testing,now 6.1+20181013-1 amd64 [installed]
libncurses6/testing,now 6.1+20181013-1 amd64 [installed,automatic]
libncursesw5/testing,now 6.1+20181013-1 amd64 [installed]
libncursesw6/testing,now 6.1+20181013-1 amd64 [installed,automatic]
ncurses-base/testing,now 6.1+20181013-1 all [installed]
ncurses-bin/testing,now 6.1+20181013-1 amd64 [installed]
ncurses-term/testing,now 6.1+20181013-1 all [installed]

Mikä avuksi?
Ilmoita


Predict 2.2.3-4+b2 löytyy Debianin ohjelmalähteiltä. Ei varmaankaan ole erityistä tarvetta sitä käännellä lähdekoodista, jolloin on tarve olla koneella yhtä sun toista ohjelmien kääntämiseen tarvittavia ohjelmia ja kirjastoja. Mutta ohjelma on saatavilla toki myös Buster/testing lähteistä:
2.3-33-gca42d22-1, jos tuollaisen välttämättä haluaa asennella.
1 VASTAUS:
Eikös tuo versio ole jo 13 vuotta vanha, joten tässä tapauksessa on tarpeen kääntää itse. Ei version uusin tarvitse olla, mutta rajansa kaikella. :)

https://github.com/kd2bd/predict

2.2.5 on vain10kk vanha.

Release 2.2.5:
By John A. Magliacane <kd2bd@amsat.org> (05-May-2018):

----------------------------------------------------------------------------

Release 2.2.4:
By John A. Magliacane <kd2bd@amsat.org> (12-Mar-2018):

-----------------------------------------------------------------------------

Release 2.2.3:
By John A. Magliacane <kd2bd@amsat.org> (15-Apr-2006):
+Lisää kommentti
Miksi yrität kääntää roottina?
2 VASTAUSTA:
Ilman tulee herja: "You need to be 'root' to install PREDICT. :-("
apuwa kirjoitti:
Ilman tulee herja: "You need to be 'root' to install PREDICT. :-("
Tuoko käännös ei olekaan normaali
./configure
make
make install
+Lisää kommentti
Sellaista vielä että onko libncursesin headerit asennett? Ne on niitä -dev loppuisia paketteja.
1 VASTAUS:
Ei ollut, siitä oli kiinni. Kiitos avusta.

sudo apt install libncurses-dev

.. korjasi tilanteen.
+Lisää kommentti

Vastaa alkuperäiseen viestiin

Predict asennus ei onnistu.

$ sudo ./configure
[sudo] password for ate:
Testing compiler...
Testing pthreads library...
Testing ncurses library... /usr/bin/ld: cannot find -lncurses
collect2: error: ld returned 1 exit status

*** Error: Compiler test for ncurses library failed. :-(

$ apt list *ncurses* | grep installed

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libncurses5/testing,now 6.1+20181013-1 amd64 [installed]
libncurses6/testing,now 6.1+20181013-1 amd64 [installed,automatic]
libncursesw5/testing,now 6.1+20181013-1 amd64 [installed]
libncursesw6/testing,now 6.1+20181013-1 amd64 [installed,automatic]
ncurses-base/testing,now 6.1+20181013-1 all [installed]
ncurses-bin/testing,now 6.1+20181013-1 amd64 [installed]
ncurses-term/testing,now 6.1+20181013-1 all [installed]

Mikä avuksi?

5000 merkkiä jäljellä

Rekisteröidy, jos haluat käyttää nimimerkkiä.

Peruuta