Ongelma maksimimerkkimäärän ylittyessä. Miten siivotaan tehokkaasti?

Anonyymi

Ulkoisesta tietolähteestä tuodossa taulukossa on soluja jossa on niin paljon merkkejä ja tekstiä, että rivikorkeudesta tulee yli 409 merkkia ja excel on siksi jakanut tiedot useammalle riville. (2-3 riviä). Huomasin, että siivoa kaavalla saan solun merkit vähenemään n. kolmasosaan. olun sisällön luettavuus kärsii, mutta paremman puutteessa menettelee. Taulukossa on satoja rivejä ja vain osassa tämä ongelma, joten en halua soveltaa kaavaa kaikkiin riveihin.

Onko sellaista kaavaa, jossa saan excelin siivoamaan solut vain jos solun merkkimäärä / rivikorkeus ylitää maksimin tai x kpl merkkejä?

4

146

    Vastaukset

    Anonyymi (Kirjaudu / Rekisteröidy)
    5000
    • Anonyymi

      =JOS(PITUUS(solu)>400;"suoritasiivous";"älä siivoa")

      tai jotain tuon suuntaista ehtolauseketta sopinee viritellä.

      • Anonyymi

        Kiitos, siivoaminen alkaa onnistumaan. Nyt alkaa rivit mahtumaan yhdelle sivulle. Ny onkin seuraava pulma, että millä kaavalla saadaan yhdistettyä nuo siivotut solut yhdelle riville. Nyt kun ylimääräiset merkit on pois niin kolmen rivin solut pitäsi mahtua yhteen.

        Eli jos sarakkeessa A on tuotenumero, jonka kuvaus on niin pitkä, että B sarakkeessa oleva tuotekuvaus on jakautunut useammalle rviville, niin nyt pitäisi ilmeisesti tehdä sellainen kaava, joka yhdistää B-sarakkeen rivit, jos A-sarakkeessa sama tuotenumero.

        Miten excelille kerrotaan, että pitää tehdä jotain niin kauan kun sarakkeessa A ei tuotenumero vaihdu?


      • Anonyymi
        Anonyymi kirjoitti:

        Kiitos, siivoaminen alkaa onnistumaan. Nyt alkaa rivit mahtumaan yhdelle sivulle. Ny onkin seuraava pulma, että millä kaavalla saadaan yhdistettyä nuo siivotut solut yhdelle riville. Nyt kun ylimääräiset merkit on pois niin kolmen rivin solut pitäsi mahtua yhteen.

        Eli jos sarakkeessa A on tuotenumero, jonka kuvaus on niin pitkä, että B sarakkeessa oleva tuotekuvaus on jakautunut useammalle rviville, niin nyt pitäisi ilmeisesti tehdä sellainen kaava, joka yhdistää B-sarakkeen rivit, jos A-sarakkeessa sama tuotenumero.

        Miten excelille kerrotaan, että pitää tehdä jotain niin kauan kun sarakkeessa A ei tuotenumero vaihdu?

        Kuvitellaan esimerkin keinoin että

        A1=koodi1 / B1=hoblaa1 / C1=B1
        A2=koodi1 / B2=hoblaa2 / C1=JOS(A2=A1;KETJUTA(C1;" ";B2);B2)
        A3=koodi1 / B3=hoblaa3 / C1=JOS(A3=A2;KETJUTA(C2;" ";B3);B3)
        A4=koodi2 / B4=hoblaa4 / C1=JOS(A4=A3;KETJUTA(C3;" ";B4);B4)
        A5=koodi3 / B5=hoblaa5 / C1=JOS(A5=A4;KETJUTA(C4;" ";B5);B5)
        A6=koodi4 / B6=hoblaa6 / C1=JOS(A6=A5;KETJUTA(C5;" ";B6);B6)
        A7=koodi4 / B7=hoblaa7 / C1=JOS(A7=A6;KETJUTA(C6;" ";B7);B7)
        jne...

        Esimerkissä siis sarakkeeseen C kasataan rivi riviltä tietoja sarakkeesra B riippuen siitä mit lukee sarakkeessa A.


    • Anonyymi

      mikä on tuo ulkoinen tietolähde, joku csv?

    Ketjusta on poistettu 0 sääntöjenvastaista viestiä.

    Luetuimmat keskustelut

    1. Ässät feikki ero

      Stefanhan se siellä Sonjan ja Sofian juhannus kuvien taustalla. Kaksi tyhmää naista ja vielä tyhmempi mies. Oliko tämä ero vain epätoivoinen yritys sa
      Kotimaiset julkkisjuorut
      104
      2303
    2. Miksi vanhat äijät

      Luulee, että nuori nainen haluaisi niiden homeista munaa? Saati että joku nuori nainen pitäisi heistä muuten? Voi reppanat. Jos sulla on paljon rahaa,
      Sinkut
      130
      1235
    3. En haluaisi uskoa että miehet ajattelee vain munallaan,

      mutta taas sain olla väärässä. Eli.. törmäsin männäviikolla puolituttuun mieheen työmatkalla. Hän kertoi, että viettäisi juhannusta minun kotikaupun
      Sinkut
      286
      1192
    4. Ärsyttävimpiä ihmistyyppejä

      Itselleni yksi ärsyttävimmistä ihmistyypeistä on takertujat. Sellaiset, joille on kohtelias, ei tuomitse heitä niin kuin monet muut tuomitsee jne. Ärs
      Sinkut
      165
      1069
    5. Somalisulhanen syö Sara Siepin suosiota

      Ei kelvannut Sara Sieppi enää kummankaan iltapäivälehden juhannustytöksi. muutenkin tykkäysmäärät näyttävät laskeneen ja ilmeisesti myös Saran seuraa
      Kotimaiset julkkisjuorut
      62
      967
    6. 58
      898
    7. Kuulispas se oikea

      henkilö mun anteeksipyynnön tään. Tajuis, että tämä aloitus oli just multa, pystyis ymmärtää mua edes jollainlailla. Turhaa sanojen helinää tääkin, lu
      Tunteet
      33
      843
    8. Juhannuksen pilaaminen ruohonleikkurilla

      Vois naapuriki ajatella onko pakko juhannusaattona leikata nurmikkoa samaan aikaan kun muut naapurit köllöttelee pihalla ja pelaavat krokettia ja naut
      Kokkola
      77
      790
    9. Eri ikäiset parit

      Tämän ajankohtaisen lapsia ahdisteleva setä-keskustelun innoittamana aloitan vähän laajemman ikäkeskustelun. Oma kantani on, että kunhan kumpikin on
      Sinkut
      111
      776
    10. Yhden viestin päässä

      Voisit juuri tälläkin hetkellä olla tässä vieressäni. Silittelisin ja paijaisin sinut puhki.
      Ikävä
      39
      751
    Aihe