Visual Studio Communityssä .NET Framework versio?

En keksi, miten voi tehdä kaikkiin .NET Frameworkeihin sopivan buildin Visual Studio Community 2015:ssä. Vai toimiiko uudemmissa, jos määrään versioksi esim. 4.6? Teen C#-ohjelmaa ja haluaisin tehdä sille yhteensopivan asennusohjelman.

Mitä .NET Frameworkejä yleensä porukoilla on käytössä?
Minulla on Windows 7:ssa .Net Framework versiot 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 ja 4.7.
Toisessa Win7-mikrossani muutoin sama, mutta puuttuu 4.7.
Ilmianna
Jaa

1 Vastaus



.NET Standard 2.0 olisi se mihin tähdätä.

Se on uusin, täysin harmonisoitu versio .NET:sta että sama ohjelma toimii kaiken kirjavilla .NET versioilla. Se on yhteensopiva:

.NET 4.61 ja uudemmat
.Mono 5.4 ja uudemmat
Xamarin iOS 10.14 ja uudemmat
Xamarin.Android 8.0 ja uudemmat
Universal Windows Platform 10.0.16299

Vanhin Microsoftin tukema on .NET 2.0 framework mikä on eri kuin .NET 2.0 standard. .NET 2.0 on yhteensopiva uusimman .NET 3.5x:n kanssa. .NET 4.0:ssa menee rikki ja uudemmat .NET 4.x frameworkit ovat yhteensopiva .NET 4.0 framework n saakka

.NET 4.x framework sitten sisältää eroavaisuuksia Universal Windows Platformiin ja .NET 2.0 Standardiin nähden, eli se .NET 2.0 Standard on juurikin tehty siihen että on yhteensopiva.
Ilmianna
Jaa

Vastaa alkuperäiseen viestiin

Visual Studio Communityssä .NET Framework versio?

En keksi, miten voi tehdä kaikkiin .NET Frameworkeihin sopivan buildin Visual Studio Community 2015:ssä. Vai toimiiko uudemmissa, jos määrään versioksi esim. 4.6? Teen C#-ohjelmaa ja haluaisin tehdä sille yhteensopivan asennusohjelman.

Mitä .NET Frameworkejä yleensä porukoilla on käytössä?
Minulla on Windows 7:ssa .Net Framework versiot 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 ja 4.7.
Toisessa Win7-mikrossani muutoin sama, mutta puuttuu 4.7.

5000 merkkiä jäljellä

Peruuta